Bug 1123079 - Host hangs when preparing for maintenance and VM's are being stopped
Summary: Host hangs when preparing for maintenance and VM's are being stopped
Keywords:
Status: CLOSED DUPLICATE of bug 1118187
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Roy Golan
QA Contact:
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 19:22 UTC by Allie DeVolder
Modified: 2019-04-28 10:45 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 07:17:54 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Allie DeVolder 2014-07-24 19:22:34 UTC
Description of problem:
There's an issue with the RHEVM infrastructure that causes a host to hang. This happens when the host is preparing for maintenance and at the same time you send a shutdown command to one of the VM's running on it, using the REST API.

This will cause migrating of the VM's to fail preventing the host from ever entering maintenance mode. The VM will also be inaccessible. Operations like "Cancel migration" and "Shutdown" will not work on it anymore. In the RHEVM gui you can see that the host has 0 VM's assigned to it, though in the VM's tab it still shows one in migrating state.

The only known resolution is to reboot the host in question.

Version-Release number of selected component (if applicable):
RHEV-M: rhevm-3.4.0-0.22
Hypervisor: vdsm-4.14.11-5.el6ev.x86_64 on Red Hat Enterprise Linux Server release 6.5

How reproducible:
Always

Steps to Reproduce:
1. On a host, create several VM's and start them.
2. Once they're up and running, switch the host to maintenance mode.
3. When it enters the state "preparing for maintenance", use the rest API to shutdown one ore more of the VM's

Actual results:
Host hangs in "Preparing for maintenance" state and VM hangs in state "Migrating".

Expected results:
Host enters maintenance mode and VM is shut down.

Additional info:

Comment 2 Oved Ourfali 2014-07-27 05:11:17 UTC
This one is somewhere between infra and virt. Marked it as virt for now, due to related work that's ongoing.
Roy - cc-ed you on this bug. Can you have a look?


Note You need to log in before you can comment on or make changes to this bug.