Bug 1123090 - unsigned packages
Summary: unsigned packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 21
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 20:18 UTC by Thomas Schweikle
Modified: 2014-07-25 16:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 16:00:19 UTC


Attachments (Terms of Use)

Description Thomas Schweikle 2014-07-24 20:18:48 UTC
Description of problem:
Many of the packages for fedora 21 are not signed as expected. Upgrades fail therefore.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install fedora 20, upgrade to fedora 21
2. yum distribution-synchronization
3. yum upgrade

Actual results:
shall work seamlessly

Expected results:
breaks with unsigned packages

Additional info:
Looks like some packages are not signed for fedora 21 (no problems with fedora 22 (rawhide) or fedora 19,20). Since yum only reports the first unsigned package it is a little bit difficult to find out which are not signed. At a first glance:
Paket ModemManager-1.2.0-3.fc21.x86_64.rpm ist nicht unterschrieben
Paket NetworkManager-wwan-0.9.10.0-1.git20140704.fc21.1.x86_64.rpm ist nicht unterschrieben
Paket ModemManager-glib-1.2.0-3.fc21.x86_64.rpm ist nicht unterschrieben
Paket audit-libs-2.3.7-4.fc21.x86_64.rpm ist nicht unterschrieben
Paket bash-4.3.18-4.fc21.x86_64.rpm ist nicht unterschrieben
Paket cups-libs-1.7.4-3.fc21.x86_64.rpm ist nicht unterschrieben
Paket dhclient-4.3.1-0.3.b1.fc21.x86_64.rpm ist nicht unterschrieben
Paket fedora-release-21-0.12.noarch.rpm ist nicht unterschrieben
Paket firewalld-config-standard-0.3.10-5.fc21.noarch.rpm ist nicht unterschrieben
...
and 500+ others

Comment 1 Jan Zeleny 2014-07-25 07:59:55 UTC
May I ask why did you file the bug against yum? Signing the packages is clearly not a yum problem. Reassigning ...

Comment 2 Dennis Gilmore 2014-07-25 16:00:19 UTC
we can not guarantee packages are signed until we freeze for alpha.


Note You need to log in before you can comment on or make changes to this bug.