Bug 11231 - blank desktop when starting kde
Summary: blank desktop when starting kde
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-04 22:38 UTC by jszabo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-06 18:47:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jszabo 2000-05-04 22:38:24 UTC
When I try to run kde from startx or gdm, all I get is a blank blue screen
with no icons on it.  Actually this has been happening since 6.1 at least.
I've been upgrading from previous redhat versions for a while, at least
since 5.2.

Joe

Comment 1 Bernhard Rosenkraenzer 2000-05-05 13:49:59 UTC
I can't reproduce it (writing this from a 6.2 machine using KDE) - do you get
any odd output on the console (such as "/usr/bin/startkde: no such file or
directory") when doing startx?

Can you try seeing where it hangs by adding "set -x" to the beginning of
/usr/bin/startkde?

Comment 2 jszabo 2000-05-06 07:12:59 UTC
It goes all the way through startkde to exec kwm.  According to ps though kfm
and krootwm are <defunct>, and kpanel isn't running.  kwm and kwmsound are
though.  I've tried reinstalling kdebase, libs, and support, and removing my .k*
and Desktop files and directories.


Joe


+ [ -f /home/joe/.kde/share/apps/kfm/magic ]
+ kcontrol -init
+ kbgndwm
++ cat /proc/devices
++ grep sound
+ hassound= 14 sound
+ [  14 sound !=  ]
+ sleep 1
+ kaudioserver
+ sleep 1
++ /usr/X11R6/bin/xdpyinfo
++ grep depths.*:.*8
+ bpp=
+ [ !  =  ]
+ sleep 2
+ sleep 1
+ sleep 1
+ sleep 1
+ exec kwmsound
+ exec kfm
+ exec krootwm
+ exec kpanel
+ exec kwm

Comment 3 jszabo 2000-05-06 18:47:59 UTC
I got it to work.  I had an old version of libqt (not from an rpm) in /usr/lib.
Now it's fine except when I mimimize there's no icon in the taskbar.

Joe


Note You need to log in before you can comment on or make changes to this bug.