Bug 1123101 - No errors in GUI if you can't contact RHSM
Summary: No errors in GUI if you can't contact RHSM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-24 21:17 UTC by Andrew Schofield
Modified: 2019-08-12 16:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-27 20:25:09 UTC


Attachments (Terms of Use)

Description Andrew Schofield 2014-07-24 21:17:29 UTC
Description of problem:

Enabling redhat repositories does not give a visual error that the repos cannot be contacted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Andrew Schofield 2014-07-24 21:21:57 UTC
Premature save there!

We run Satellite 6 behind a proxy server. If the proxy servers are not configure then Content -> Red Hat Repositories and trying to view a repository set (to enable a repo) does not give a visual clue (the wheel just continually spins whilst trying to open the list) that RHN cannot be contacted.

Comment 2 RHEL Product and Program Management 2014-07-24 21:43:46 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 8 Chris Duryee 2018-03-27 20:25:09 UTC
I tested this on 6.2.14:

test #1: edit /etc/hosts to point cdn.redhat.com to 127.0.0.1

result: got ssl error (correct)

test #2: block outbound traffic to cdn.redhat.com's IP via iptables

result: got timeout error after a few minutes (correct)

marking closed/currentrelease


Note You need to log in before you can comment on or make changes to this bug.