Bug 1123136 - Evolution crashes when adding a header to show
Summary: Evolution crashes when adding a header to show
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
: 1128607 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 00:17 UTC by Carson Chittom
Modified: 2015-03-05 06:37 UTC (History)
6 users (show)

Fixed In Version: evolution-3.8.5-26
Doc Type: Bug Fix
Doc Text:
Cause: write a new header name into Edit->Preferences->Mail Preferences->Headers tab and click Add button beside the name Consequence: evolution crashes Fix: correct code to not dereference NULL Result: evolution doesn't crash and adds the header to the message preview
Clone Of:
Environment:
Last Closed: 2015-03-05 06:37:33 UTC


Attachments (Terms of Use)
gdb trace with evolution-debuginfo installed (16.52 KB, text/plain)
2014-07-25 07:47 UTC, manuel wolfshant
no flags Details
evo patch (838 bytes, patch)
2014-07-29 09:33 UTC, Milan Crha
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0305 normal SHIPPED_LIVE evolution bug fix update 2015-03-05 11:36:15 UTC
CentOS 7419 None None None Never
GNOME Bugzilla 702959 None None None Never

Description Carson Chittom 2014-07-25 00:17:41 UTC
Description of problem: When selecting the "Mailer" header in preferences, Evolution crashes


Version-Release number of selected component (if applicable): 3.8.5


How reproducible:


Steps to Reproduce:
1) Start Evolution
2) Select Edit -> Preferences
3) Select Mail Preferences
4) Select Headers tab
5) Click on the checkbox by "Mailer"
6) Evolution crashes

Actual results: seg fault


Expected results: Box checked and "X-Mailer" and "User-Agent" headers added to display of messages


Additional info: Originally reported in the CentOS bug tracker as bug 7419

Comment 2 Milan Crha 2014-07-25 06:47:50 UTC
Thanks for a bug report. Could you paste here a backtrace of the crash with a debuginfo package for evolution installed, thus it'll show where exactly evolution crashed, please? Also provide exact package versions, because the "3.8.5" is not going to change any time soon.

To get a backtrace, you can do it like this (after installing the debug info) from a terminal:
   $ gdb evolution --ex r --ex bt --ex q
Which will run evolution under gdb, then reproduce the crash, which will print the backtrace and then will try to quit gdb. There will be needed some confirmations, also during the backtrace print, in case it'll be long enough.

Comment 3 manuel wolfshant 2014-07-25 07:47:49 UTC
Created attachment 920881 [details]
gdb trace with evolution-debuginfo installed

Comment 4 manuel wolfshant 2014-07-25 07:50:03 UTC
[root@pc65 ~]# rpm -qa evolution\*
evolution-debuginfo-3.8.5-22.el7_0.1.x86_64
evolution-data-server-3.8.5-24.el7_0.x86_64
evolution-3.8.5-22.el7_0.1.x86_64

The system is a CentOS-7 installed as minimal followed by "yum install evolution".

Comment 5 manuel wolfshant 2014-07-25 07:53:57 UTC
As a side note, the problem persists even if the system is fully updated

Comment 6 Milan Crha 2014-07-29 08:15:22 UTC
Thanks for the update. I just found an upstream bug report [1] about the same, which is still opened.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=702959

Comment 7 Milan Crha 2014-07-29 09:33:08 UTC
Created attachment 922092 [details]
evo patch

for evolution;

This fixes the crash. A reproducer:
a) go to Edit->Preferences->Mail Preferences->Headers tab
b) write a new header name
c) click Add button beside the header name

Evolution crashes on NULL dereference.

Comment 8 Milan Crha 2014-08-25 14:42:12 UTC
*** Bug 1128607 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2015-03-05 06:37:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0305.html


Note You need to log in before you can comment on or make changes to this bug.