Bug 1123203 - [fork][origin_ui_190]Incorrect region name shown from web console
Summary: [fork][origin_ui_190]Incorrect region name shown from web console
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 06:28 UTC by XiuJuan Wang
Modified: 2015-05-15 01:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:49:42 UTC


Attachments (Terms of Use)

Description XiuJuan Wang 2014-07-25 06:28:14 UTC
Description of problem:
Create some regions, such as 'region_1','region1','region_wang','Region_1','region+1'.Then check the regions on app creating page.
All of regions show with upper case of the first word. The underline in 'region_1' and 'Region_1' both have gone, shown as 'Region 1'. 'region-1' shows as 'Region-1'.

Create some apps with this regions.app/show page shows same wrong region with app creating page. 

Check admin-console page,the gear page show correct region/zone name.

Version-Release number of selected component (if applicable):
fork_ami_origin_ui_190_1235

How reproducible:
always

Steps to Reproduce:
1.Create some regions, such as 'region_1','region1','region_wang','Region_1','region+1'
2.Check the regions from web console
3.

Actual results:
step 2
The regions show as:
'Region 1','Region1','Region wang','Region 1','Region+1'

Expected results:
The regions name could show correctly.

Additional info:

Comment 1 Jessica Forrester 2014-07-25 13:07:00 UTC
Looks like a side effect of calling humanize on region name

Comment 2 Jeff Cantrill 2014-07-25 17:52:22 UTC
updated to remove humanize and titleize on region, gear_groups, or gear_size

Comment 3 Jessica Forrester 2014-07-28 13:21:39 UTC
Fixed as part of https://github.com/openshift/origin-server/pull/5633

Comment 4 XiuJuan Wang 2014-07-29 05:53:42 UTC
Checked in devenv_5020, can't reproduce this bug.Move bug to verified.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.