Bug 1123262 - [Regression] satyr generates DUPHASH value for koopses consisting only from unreliable frames
Summary: [Regression] satyr generates DUPHASH value for koopses consisting only from u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: satyr
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Milata
QA Contact: Lukas Zachar
URL:
Whiteboard:
: 1142342 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 07:52 UTC by Jakub Filak
Modified: 2019-03-06 00:44 UTC (History)
1 user (show)

Fixed In Version: satyr-0.13-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:26:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0556 normal SHIPPED_LIVE abrt, libreport, and satyr bug fix and enhancement update 2015-03-05 16:44:43 UTC

Description Jakub Filak 2014-07-25 07:52:32 UTC
Description of problem:
satyr does not find any reliable frame for hashing and generates the hash value from empty string. ABRT uses the hash value to identify duplicates in Bugzilla, so it means that all unreliable oopses are reported as a single Bugzilla bug. However, that koopses should not be reported at all. In order to fix this issue, satyr must return NULL from the hashing function for unreliable koopses.

Version-Release number of selected component (if applicable):
abrt-2.1.11-12.el7

Additional info:
Upstream commit https://github.com/abrt/satyr/commit/d818117a985ed5bdd00eafbc6ef9ce3f9ec54c58 fixes this bug.

Comment 2 Martin Milata 2014-09-17 14:14:13 UTC
*** Bug 1142342 has been marked as a duplicate of this bug. ***

Comment 5 Jakub Filak 2014-11-14 13:09:08 UTC
The upstream patch includes a test case:
https://github.com/abrt/satyr/commit/d818117a985ed5bdd00eafbc6ef9ce3f9ec54c58

ABRT tests satyr's ability to recognize an unreliable oops in 'Drop unreliable OOPS' phase of 'oops-processing' integration test[1] ('oops_no_reliable_frame' file [2]).

1: https://github.com/abrt/abrt/tree/master/tests/runtests/oops-processing
2: https://github.com/abrt/abrt/blob/master/examples/oops_no_reliable_frame.test

Comment 8 errata-xmlrpc 2015-03-05 13:26:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0556.html


Note You need to log in before you can comment on or make changes to this bug.