Bug 1123281 - lvm-set-filter stopped working with lvm2 >= 2.02.108
Summary: lvm-set-filter stopped working with lvm2 >= 2.02.108
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 08:40 UTC by Richard W.M. Jones
Modified: 2014-08-28 16:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-28 16:34:11 UTC


Attachments (Terms of Use)
root.log (185.45 KB, text/plain)
2014-07-25 08:40 UTC, Richard W.M. Jones
no flags Details
build.log (2.54 MB, text/plain)
2014-07-25 08:41 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2014-07-25 08:40:20 UTC
Description of problem:

Or at least, it stopped working in Koji.  The full build log is
attached, but the relevant bits are:

LVM filter test failed.  Actual output was:
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
VG1
VG2
/builddir/build/BUILD/libguestfs-1.27.23/run: command failed with exit code 1
FAIL: test-lvm-filtering.sh

However I am unable to reproduce this on my Rawhide machine.

Version-Release number of selected component (if applicable):

libguestfs 1.27.23
lvm2-2.02.108-1.fc22.x86_64

How reproducible:

Happened twice in Koji, never on my local Rawhide machine.

Comment 1 Richard W.M. Jones 2014-07-25 08:40:56 UTC
Created attachment 920908 [details]
root.log

Comment 2 Richard W.M. Jones 2014-07-25 08:41:22 UTC
Created attachment 920909 [details]
build.log


Note You need to log in before you can comment on or make changes to this bug.