Bug 1123288 - [virtio-win][netkvm]BOSD occurs during guest reboot after disable nic when netserver running
Summary: [virtio-win][netkvm]BOSD occurs during guest reboot after disable nic when ne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1100308
TreeView+ depends on / blocked
 
Reported: 2014-07-25 08:55 UTC by Mike Cao
Modified: 2015-11-24 08:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 08:42:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Mike Cao 2014-07-25 08:55:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):
3.10.0-121.el7.x86_64
qemu-kvm-1.5.3-62.el7.x86_64
seabios-bin-1.7.2.2-12.el7.x86_64
both virtio-win-prewhql-84 and virtio-win-prewhql-87
win8.1-32 guest

How reproducible:
100%

Steps to Reproduce:
1.Start VM w/ virtio-net-pci
 /usr/libexec/qemu-kvm -name 084NICBLUE32C06 -enable-kvm -m 6G -smp 4 -uuid e6dca2b3-1ac9-4abd-a0b0-6ba146b555d8 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/084NICBLUE32C06,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=084NICBLUE32C06,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_1_enterprise_x86_dvd_2972289.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=084NICBLUE32C06.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:1c:66:1c:d6,bus=pci.0,mq=on
2.in the guest #netserver
3.on the host start 100 instance of netperf 
for ((i=1;i<=100;i++)); do netperf -D 1 -H 10.66.8.223 -l 100 -C -c -t TCP_STREAM -- -m 65535 & done
4.during step 3 (more or less 30 secs) ,disable virito-nic driver in the device manager 
5. Wait for 5-10 mins , restart guest 
#shutdown -t 0 -r -f 

Actual results:
after step4 device manager will hang ,restart a new device manager it will shows 'No drivers are installed for the device 'in VirtIO Ethernet Adapater properties General tab
after step5 ,guest will bsod with 'DRIVER_PWOER_STATE_FAILURE'

Expected results:
after step4 ,no hang in guest device manager ,driver can
after step5 no bsod occurs 

Additional info:
Using the exactly steps above while regard guest as netperf client will not hit the issue.

Comment 3 Yossi Hindin 2014-11-20 19:14:54 UTC
It looks like the bug has been already fixed. Please, test it again with the latest virtio-win build.

   Thank you in advance,
       Joseph Hindin

Comment 4 Mike Cao 2014-11-26 08:33:05 UTC
(In reply to Yossi Hindin from comment #3)
> It looks like the bug has been already fixed. Please, test it again with the
> latest virtio-win build.
> 
>    Thank you in advance,
>        Joseph Hindin

Sorry for the late response first .

Steps same with comment #0

1.test on build87 & qemu-kvm-1.5.3-82.el7.x86_64 -> reproduced 
2.test on build94 & qemu-kvm-1.5.3-82.el7.x86_64 -> Fixed
3.test on build87 & qemu-kvm-rhev-2.1.2-12.el7   -> can not reproduce(works fine)
3.test on build94 & qemu-kvm-rhev-2.1.2-12.el7   -> can not reproduce(works fine)

Based on above ,This issue has been fixed.

Mike

Comment 5 Yan Vugenfirer 2014-11-26 11:05:07 UTC
Thanks!

Comment 7 Mike Cao 2014-12-01 02:43:15 UTC
Move to verified according to comment #4.

Comment 12 errata-xmlrpc 2015-11-24 08:42:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.