Bug 1123319 - Misalignment in 'New Cluster' dialog
Summary: Misalignment in 'New Cluster' dialog
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.5.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Greg Sheremeta
QA Contact: Petr Kubica
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta3
TreeView+ depends on / blocked
 
Reported: 2014-07-25 10:04 UTC by Lijun Li
Modified: 2016-02-10 19:04 UTC (History)
10 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:08:15 UTC
oVirt Team: Infra


Attachments (Terms of Use)
Misalignment in 'New Cluster' dialog (73.64 KB, image/png)
2014-07-25 10:06 UTC, Lijun Li
no flags Details
fix (39.47 KB, image/png)
2014-08-26 02:22 UTC, Greg Sheremeta
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31022 None ABANDONED [fr_FR][Admin Portal] Misalignment in 'New Cluster' Never
oVirt gerrit 31938 master MERGED webadmin: fix alignment in New Cluster dialog / Optimization Never
oVirt gerrit 32433 ovirt-engine-3.5 MERGED webadmin: fix alignment in New Cluster dialog / Optimization Never
oVirt gerrit 33225 master MERGED webadmin: fix alignment in New Cluster dialog / Scheduling policy Never
oVirt gerrit 33351 master MERGED webadmin: tweak info icons in cluster popup Never
oVirt gerrit 33371 ovirt-engine-3.5 MERGED webadmin: tweak info icons in cluster popup Never
oVirt gerrit 33377 ovirt-engine-3.5 MERGED webadmin: fix alignment in New Cluster dialog / Scheduling policy Never

Description Lijun Li 2014-07-25 10:04:22 UTC
Description of problem:
[fr_FR][Admin Portal] Misalignment in 'New Cluster' dialog.

Version-Release number of selected component (if applicable):
3.5.0-0.4.master.el6_5

How reproducible:
100%

Steps to Reproduce:
1. Login Admin Portal.
2. Click 'Clusters'->'New'.
3. Click 'Optimization'.
4. Click 'Cluster Policy'.

Actual results:
[fr_FR][Admin Portal] Misalignment in 'New Cluster' dialog.

Expected results:
Those strings should be alignment with radio button/check box in one line.

Additional info:
Please see the attached screen-shot.

Comment 1 Lijun Li 2014-07-25 10:06:13 UTC
Created attachment 920944 [details]
Misalignment in 'New Cluster' dialog

Comment 2 Eli Mesika 2014-08-04 14:08:11 UTC
Einav, please review the proposed patch and let me know if a more general approach should be taken here by the UX team

Comment 3 Einav Cohen 2014-08-13 17:53:07 UTC
from Vojtech:

"""
There are two problems (i.e. New Cluster dialog / Optimization side-tab):

1, assume the label fits entirely in dialog's content pane:
   problem: part of label is in-line with radio, rest of label is below
   quick fix: remove "width: 90%" on <div> content under <label>

2, assume the label is longer than (doesn't fit) dialog's content pane:
   problem: entire label is rendered below the radio
   quick fix: set "display: inline" on <label> and its <div> content

Increasing width of dialog doesn't fix the root cause, I think we should
fix this on default CSS style (widget/infra) level.
"""

@Greg - your take on this?

Comment 4 Greg Sheremeta 2014-08-26 02:22:30 UTC
Created attachment 930689 [details]
fix

Comment 5 Greg Sheremeta 2014-08-26 02:24:43 UTC
I agree with Vojtech that those are the problems.

For some reason, only this dialog had those CSS values. So it wasn't really a 'global' problem. But I went ahead and posted a fix that fixes the root cause.

Comment 6 Eyal Edri 2014-09-10 20:21:42 UTC
fixed in vt3, moving to on_qa.
if you believe this bug isn't released in vt3, please report to rhev-integ@redhat.com

Comment 7 Petr Kubica 2014-09-16 14:50:23 UTC
Alignment in tab 'Cluster Policy' in French language is still the same as shown on the right side of the attached screen-shot "Misalignment in 'New Cluster' dialog"

Comment 8 Greg Sheremeta 2014-09-16 16:15:09 UTC
gah, I totally missed that that was on a different tab. Sorry -- thanks.

Comment 9 Greg Sheremeta 2014-09-25 18:34:50 UTC
this should be all set now

Comment 10 Eyal Edri 2014-09-28 11:29:37 UTC
this bug was moved to MODIFIED before vt4 build date thus moving to ON_QA.
if you belive this bug isn't in vt4, please report to rhev-integ@redhat.com

Comment 11 Greg Sheremeta 2014-10-01 14:46:45 UTC
This bug fix isn't in vt4. I reported to rhev-integ@redhat.com per Eyal's instructions

Comment 12 Eyal Edri 2014-10-07 07:12:52 UTC
this bug status was moved to MODIFIED before engine vt5 was built,
hence moving to on_qa, if this was mistake and the fix isn't in,
please contact rhev-integ@redhat.com

Comment 13 Petr Kubica 2014-10-08 13:26:34 UTC
Verified in rhevm 3.5.0-0.14.beta.el6ev

Comment 14 Eyal Edri 2015-02-17 17:08:15 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.