Bug 1123320 - Networkmanager does not set the mtu
Summary: Networkmanager does not set the mtu
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 10:05 UTC by Darryl Bond
Modified: 2015-06-29 21:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:45:24 UTC


Attachments (Terms of Use)

Description Darryl Bond 2014-07-25 10:05:46 UTC
Description of problem: Network manager does not change the MTU when instructed by nmcli, GUI or editing the config files


Version-Release number of selected component (if applicable):
NetworkManager.x86_64           1:0.9.9.0-41.git20131003.fc20

How reproducible:
Very

Steps to Reproduce:
1. nmcli connection modify p4p1 802-3-ethernet.mtu 9000
2. Check that MTU=9000 has been added to /etc/sysconfig/network-scripts/ifcfg-p4p1
3. ifconfig shows that the MTU is still 1500, reboot and still 1500
4. ifconfig p4p1 mtu 9000 sets the MTU for the current boot
Actual results:
ifconfig p4p1
p4p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

Expected results:
ifconfig shows that the interface MTU is 9000 and survives reboots.
p4p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 9000

Additional info:
This same behaviour on Centos 7.

Comment 1 Jirka Klimes 2014-11-10 08:38:14 UTC
There was a problem of setting MTU from DHCP (bug 1047083), but that is fixed just in -41.git20131003.fc20.

However, in your case, it may only be a configuration issue. Please realize that your first command only modifies a connection profile named p4p1. You need to re-activate it so that the changes take effect. Is the MTU correctly applied when you do nmcli con up p4p1?

Can you check what connection is activated after reboot?
$ nmcli con show active

And list all connections
$ nmcli con show

Can you attach /var/log/messages too?

Comment 2 Darryl Bond 2014-11-11 01:37:50 UTC
I just tried it in an up-to-date VM
# nmcli connection show active
nmcli connection show active
NAME  UUID                                  DEVICES  DEFAULT  VPN  MASTER-PATH 
eth0  b3394931-b18b-49ab-b7cd-042d13ee6b53  eth0     yes      no   --          
# nmcli con show
nmcli con show
NAME  UUID                                  TYPE            TIMESTAMP-REAL                
eth0  b3394931-b18b-49ab-b7cd-042d13ee6b53  802-3-ethernet  Tue 11 Nov 2014 11:29:28 AEST 
# nmcli connection modify eth0 802-3-ethernet.MTU 9000
# cat ifcfg-eth0 
TYPE="Ethernet"
BOOTPROTO="dhcp"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
NAME="eth0"
UUID="b3394931-b18b-49ab-b7cd-042d13ee6b53"
ONBOOT="yes"
HWADDR=52:54:00:DC:79:AE
MTU=9000
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
# nmcli connection up eth0
# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 9000

Also MTU=9000 after a reboot.
The only difference to previous attempt was the 'nmcli connection up eth0' unless some other update fixed it.

This is the expected behavior.

Comment 3 Fedora End Of Life 2015-05-29 12:28:16 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2015-06-29 21:45:24 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.