Bug 1123362 - installation of rhel-osp-installer fails
Summary: installation of rhel-osp-installer fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: Installer
Assignee: Marek Hulan
QA Contact: Udi
URL:
Whiteboard:
: 1123407 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 12:36 UTC by Mike Burns
Modified: 2014-08-21 18:06 UTC (History)
6 users (show)

Fixed In Version: foreman-installer-1.5.0-0.6.RC2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:06:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Mike Burns 2014-07-25 12:36:35 UTC
Description of problem:

During rhel-osp-installer execution, the following errors come up.  This is due to the fix for bug 1121411 in foreman-installer.

 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppet.yml20140725-3881-1tg8ygw-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppet.yml20140725-3881-1tg8ygw-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[puppet]/File[/etc/foreman-proxy/settings.d/puppet.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppet.yml20140725-3881-1tg8ygw-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dhcp.yml20140725-3881-kff8ul-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dhcp.yml20140725-3881-kff8ul-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[dhcp]/File[/etc/foreman-proxy/settings.d/dhcp.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dhcp.yml20140725-3881-kff8ul-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/bmc.yml20140725-3881-1i18m8q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/bmc.yml20140725-3881-1i18m8q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[bmc]/File[/etc/foreman-proxy/settings.d/bmc.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/bmc.yml20140725-3881-1i18m8q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dns.yml20140725-3881-a0782q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dns.yml20140725-3881-a0782q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[dns]/File[/etc/foreman-proxy/settings.d/dns.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/dns.yml20140725-3881-a0782q-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/realm.yml20140725-3881-1070n8x-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/realm.yml20140725-3881-1070n8x-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[realm]/File[/etc/foreman-proxy/settings.d/realm.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/realm.yml20140725-3881-1070n8x-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppetca.yml20140725-3881-ui2k7o-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppetca.yml20140725-3881-ui2k7o-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[puppetca]/File[/etc/foreman-proxy/settings.d/puppetca.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/puppetca.yml20140725-3881-ui2k7o-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/tftp.yml20140725-3881-1rbryx1-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/tftp.yml20140725-3881-1rbryx1-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Config/Foreman_proxy::Settings_file[tftp]/File[/etc/foreman-proxy/settings.d/tftp.yml]/ensure: change from absent to file failed: Could not set 'file' on ensure: cannot generate tempfile `/etc/foreman-proxy/settings.d/tftp.yml20140725-3881-1rbryx1-9' at 30:/usr/share/foreman-installer/modules/foreman_proxy/manifests/settings_file.pp
 /Stage[main]/Foreman_proxy::Service/Service[foreman-proxy]: Failed to call refresh: Could not start Service[foreman-proxy]: Execution of '/sbin/service foreman-proxy start' returned 1: Starting foreman-proxy: /usr/share/foreman-proxy/bin/../lib/sinatra-patch.rb:22:in `run!': private method `gsub' called for nil:NilClass (NoMethodError)
 /Stage[main]/Foreman_proxy::Service/Service[foreman-proxy]: Could not start Service[foreman-proxy]: Execution of '/sbin/service foreman-proxy start' returned 1: Starting foreman-proxy: /usr/share/foreman-proxy/bin/../lib/sinatra-patch.rb:22:in `run!': private method `gsub' called for nil:NilClass (NoMethodError)

Version-Release number of selected component (if applicable):
foreman-installer-1.5.0-0.5.RC2.el6ost

How reproducible:
Always

Steps to Reproduce:
1.run rhel-osp-installer with this version of foreman-installer
2.
3.

Actual results:
fails

Expected results:
succeeds

Additional info:
Easy fix:  roll back to previous foreman-installer package which will cause bug 1121411 to go back to assigned

Comment 1 Mike Burns 2014-07-25 12:42:33 UTC
bug 1121411 pulled a few patches back due to conflicts which are incompatible with current foreman version.  We're rebasing the patch to remove the conflicts and minimize the change.

Comment 3 Mike Burns 2014-07-25 14:30:27 UTC
*** Bug 1123407 has been marked as a duplicate of this bug. ***

Comment 7 Udi 2014-08-07 10:56:03 UTC
Unable to reproduce in rhel-osp-installer-0.1.6-5.el6ost.noarch

Comment 8 errata-xmlrpc 2014-08-21 18:06:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.