Bug 1123420 - resize2fs says "Please run 'e2fsck -f /dev/VG/Root' first." but I just ran e2fsck (arm64)
Summary: resize2fs says "Please run 'e2fsck -f /dev/VG/Root' first." but I just ran e2...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs
Version: rawhide
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Sandeen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2014-07-25 15:02 UTC by Richard W.M. Jones
Modified: 2014-07-28 14:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 14:26:51 UTC


Attachments (Terms of Use)
e2fsck.log (122.18 KB, text/plain)
2014-07-25 15:02 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2014-07-25 15:02:24 UTC
Created attachment 921000 [details]
e2fsck.log

Description of problem:

This works on x86-64.  However on aarch64:

# e2fsck -fy /dev/VG/Root
e2fsck 1.42.11 (09-Jul-2014)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
ROOT: 46/8192 files (2.2% non-contiguous), 1628/8192 blocks
# resize2fs /dev/VG/Root
resize2fs 1.42.11 (09-Jul-2014)
Please run 'e2fsck -f /dev/VG/Root' first.

Obviously I've just done that.

/dev/VG/Root is not mounted.

Version-Release number of selected component (if applicable):

kernel 3.16.0-0.rc6.git1.1.efirtcfix1.fc22.aarch64
e2fsprogs-1.42.11-2.fc21.aarch64

How reproducible:

100%

Steps to Reproduce:
1. In libguestfs test suite, do: make -C builder check

Additional info:

See attachment for full output, kernel messages, etc.

Comment 1 Eric Sandeen 2014-07-26 23:39:06 UTC
what does dumpe2fs -h say after the fsck -fy?

Comment 2 Richard W.M. Jones 2014-07-28 08:06:59 UTC
e2fsck -fy /dev/VG/Root
e2fsck 1.42.11 (09-Jul-2014)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
ROOT: 46/8192 files (2.2% non-contiguous), 1628/8192 blocks
dumpe2fs 1.42.11 (09-Jul-2014)
Filesystem volume name:   ROOT
Last mounted on:          /
Filesystem UUID:          01234567-0123-0123-0123-012345678902
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      ext_attr resize_inode dir_index filetype sparse_super large_file
Filesystem flags:         unsigned_directory_hash 
Default mount options:    user_xattr acl
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              8192
Block count:              8192
Reserved block count:     409
Free blocks:              6564
Free inodes:              8146
First block:              0
Block size:               4096
Fragment size:            4096
Reserved GDT blocks:      1
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         8192
Inode blocks per group:   256
Filesystem created:       Thu Jan  1 00:00:08 1970
Last mount time:          Thu Jan  1 00:00:12 1970
Last write time:          Thu Jan  1 00:00:06 1970
Mount count:              0
Maximum mount count:      -1
Last checked:             Thu Jan  1 00:00:08 1970
Check interval:           0 (<none>)
Lifetime writes:          5488 kB
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:\t          128
Default directory hash:   half_md4
Directory Hash Seed:      238d2b7b-bc36-4fc3-935e-8555f8235b21

resize2fs /dev/VG/Root
resize2fs 1.42.11 (09-Jul-2014)
Please run 'e2fsck -f /dev/VG/Root' first.

Comment 3 Richard W.M. Jones 2014-07-28 08:12:53 UTC
Ah I see what's happening here.  The system clock (of the VM) is
set to the Unix epoch for some reason.  Probably kvmclock is
broken in some way.  This is probably not a bug ...

Comment 4 Richard W.M. Jones 2014-07-28 14:26:51 UTC
OK I fixed this by enabling a RTC source in the kernel (bug 1123882).


Note You need to log in before you can comment on or make changes to this bug.