Bug 1123441 - tenant_network_type is hard-coded to 'vxlan' for networker node and compute nodes
Summary: tenant_network_type is hard-coded to 'vxlan' for networker node and compute n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 16:10 UTC by Scott Seago
Modified: 2014-09-08 05:44 UTC (History)
5 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.1.21.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:36:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Scott Seago 2014-07-25 16:10:22 UTC
Description of problem:
tenant_network_type is hard-coded to 'vxlan' for networker node and compute nodes rather than being set to the user-specified tenant network type from the UI

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. When creating a neutron deployment, select 'gre' as the tenant network type in the neutron settings wizard page
2. Look at 'tenant network type' in the advanced configuration view for the networker service (if non-HA) and on the compute service (regardless of HA/non-HA) -- you'll see 'vxlan' rather than the selected 'gre'

Actual results:
'tenant network type' is 'vxlan' on compute/networker

Expected results:
'tenant network type' is 'gre' on compute/networker

Additional info:

Comment 2 Scott Seago 2014-07-25 16:15:45 UTC
Fix on master in merged PR https://github.com/theforeman/staypuft/pull/240

Comment 3 Scott Seago 2014-07-25 16:24:36 UTC
0.1.x branch commit: 1aa679aa2d89e9928a8277fc483462e793285a50
upstream build forthcoming

Comment 7 Alexander Chuzhoy 2014-08-01 22:01:19 UTC
Verified: rhel-osp-installer-0.1.6-5.el6ost.noarch


I see the following:

tenant network type: <%= @host.deployment.neutron.network_segmentation %>

and below that field it says: "evaluates to: gre"

Comment 8 errata-xmlrpc 2014-08-04 18:36:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.