Bug 112345 - IPv6 networking should be turn on by default
IPv6 networking should be turn on by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-17 21:15 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 22:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2003-12-17 21:15:38 EST
Description of problem:
IPv6 networking should be turned on by default in install,
so that IPv6 networking is available by default.

How reproducible:
every time

Steps to Reproduce:
1. Install distro with anaconda
2. grep /etc/sysconf/network NETWORKING_IPV6
  
Actual results:
IPv6 networking is not enabled in /etc/sysconf/network.

Expected results:
NETWORKING_IPV6=yes should be set in /etc/sysconf/network.

Additional info:
If necessary there could be a check box to control whether
IPv6 networking is configured or not, but it should be on
by default.  IPv6 is gaining importance worldwide, and
we need to improve support for it.  Turning it on by default
is any important first step in this process.
Comment 1 Jeremy Katz 2003-12-18 01:07:38 EST
Turning it on without actually getting into configuration seems less
than useful to me :)

That said, I am somewhat interested in looking at ipv6 support in
anaconda overall, it's just a question of time. 
Comment 2 Kaj J. Niemi 2003-12-18 20:02:30 EST
Turning it on by default might not really be what you want.

Since IPv6 end hosts are able to autoconfigure themselves to some
extent (the prefix, gateway(s), etc. but not resolvers which is
something DHCPv6 provides) might hose the configuration for some users
who have enabled IPv6 on their Cisco routers towards their LAN(s). 

This will quite likely result in the following:

- install fails since there's really no route to the world outside the
lan and the wrongly configured gateway router(s)
- some services behave differently on dual-stack systems
- some services are not able to function over IPv6 at all

That said, IPv6 is a nice thing to have around but it should be
enabled manually by the user during the network configuration part of
the installation or by someone kickstarting say a rack of servers at
the same time. O:-)
Comment 3 Jens Petersen 2004-01-15 01:55:03 EST
Though I agree to an extent, I would argue that it is exactly in
order to get those kinds of potential problems solved that IPv6 *should*
be enabled by default.  Certainly testing it during the development
cycle at least would give valuable feedback I feedback.
Comment 4 Jens Petersen 2004-01-15 02:02:11 EST
Responding to comment 1, basic IPv6 host configuration is automatic
so configuration would only be needed for v6 routers, which
should probably be done in redhat-config-network like
it is for IPv4 I think.
Comment 5 Leon Ho 2004-04-06 20:19:10 EDT
Are we doing this on FC2? Or are we deferring to later release?
Comment 6 Jens Petersen 2004-04-07 07:20:45 EDT
Actually, IPv6 is already on by default in FC2, and has been for a while.
(Not quite sure how though. :-)
Comment 7 Jens Petersen 2004-07-26 22:50:12 EDT
Since IPv6 seems to be on by default in FC2, closing this for now.

Note You need to log in before you can comment on or make changes to this bug.