Bug 1123460 - Rubygem-Staypuft: Deployment of nonHA Nova (Vlan) gets paused with errors on 55.2%.
Summary: Rubygem-Staypuft: Deployment of nonHA Nova (Vlan) gets paused with errors on...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 18:00 UTC by Alexander Chuzhoy
Modified: 2014-08-08 18:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 18:12:39 UTC


Attachments (Terms of Use)
/var/log/messages file from the compute node. (155.02 KB, text/plain)
2014-07-25 18:02 UTC, Alexander Chuzhoy
no flags Details

Description Alexander Chuzhoy 2014-07-25 18:00:38 UTC
Rubygem-Staypuft:  Deployment of nonHA Nova (Vlan) gets paused with errors on 55.2%.


Environment: poodle 2014-07-25.2
rhel-osp-installer-0.1.6-2.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.4.el6ost.noarch

Steps to reproduce:
1. install rhel-osp-installer.
2. Configure/run a deployment of nova network (1 controller +2 compute) with: vlan Tenant Network Type, vlan range: 10:100, floating IP range for external: 192.168.0.128/25, floating IP range for tenant: 192.168.32.0/22  and eth0 for both: external and tenant networks.

Result: 
The deployment gets stuck on 55.2%.
Some investigation shows: that a compute nodes receives the following error on attempt to run puppet:

Error: Execution of '/usr/bin/nova-manage network create novanetwork 192.168.32.0/22 91  --vlan 10' returned 1: Command failed, please check log for more info
Error: /Stage[main]/Nova::Network/Nova::Manage::Network[nova-vm-net]/Nova_network[nova-vm-net]/ensure: change from absent to present failed: Execution of '/usr/bin/nova-manage network create novanetwork 192.168.32.0/22 91  --vlan 10' returned 1: Command failed, please check log for more info


Expected result:
the deployment should pass 100%.

Comment 1 Alexander Chuzhoy 2014-07-25 18:02:43 UTC
Created attachment 921038 [details]
/var/log/messages file from the compute node.

Comment 4 Mike Burns 2014-07-25 18:33:58 UTC
We explicitly say "NOTE: Best practice is to use a different interface than the interface used for pxe/provisioning the node. This practice is mandatory if VLAN is chosen as the tenant network type." in the wizard.  Allowing configuration with them the same is a bug, but not a blocker for GA2

Comment 5 Alexander Chuzhoy 2014-07-25 19:04:59 UTC
I missed it.
Amm,
Need to enforce the check before starting the deployment.
Also might want to highlight the note or make it bold.

Comment 6 Mike Burns 2014-08-05 18:12:39 UTC
this is a valid error due to bad configuration.  closing as notabug


Note You need to log in before you can comment on or make changes to this bug.