Bug 1123479 - Docker Enablement
Summary: Docker Enablement
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Release Test Team
URL:
Whiteboard:
: 1125842 (view as bug list)
Depends On:
Blocks: 1125409 1144140 1190764
TreeView+ depends on / blocked
 
Reported: 2014-07-25 19:27 UTC by Jay Greguske
Modified: 2019-04-16 14:14 UTC (History)
4 users (show)

Fixed In Version: anaconda-19.31.86-1
Doc Type: Enhancement
Doc Text:
Feature: Add kickstart options to support creating smaller installations for use with things such as Docker. Reason: Docker doesn't need a full installation. Result: Several kickstart changes were made to support this. The %packages --nocore option disables installation of the @core group. Adding -kernel to the package list will prevent installation of any kernel package. Adding bootloader --disabled will prevent installation of a bootloader. And %packages --instLangs will prevent installation of language packages.
Clone Of:
: 1123481 1125409 1144140 (view as bug list)
Environment:
Last Closed: 2015-03-05 14:02:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC

Description Jay Greguske 2014-07-25 19:27:21 UTC
To support Anaconda building Docker™ images, a handful of feature enhancements should be merged into RHEL:

- disable kernel installation
- disable installation of the boot loader
- prevent installing @core
- limit the installation of localization packages and documentation

The kickstart syntax introduced with these feature enhancements allows us to generate very minimal base images.

Comment 1 Chris Lumens 2014-08-18 13:24:32 UTC
*** Bug 1125842 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2015-03-05 14:02:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.