Bug 1123496 - Rubygem-Staypuft: Need to shrink the suggested vlan range in network configuration page.
Summary: Rubygem-Staypuft: Need to shrink the suggested vlan range in network configu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 20:18 UTC by Alexander Chuzhoy
Modified: 2014-08-21 18:06 UTC (History)
2 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:06:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Alexander Chuzhoy 2014-07-25 20:18:13 UTC
Rubygem-Staypuft:  Need to shrink the suggested vlan range in network configuration page.


Environment:
rhel-osp-installer-0.1.6-2.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.4.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer.
2. create a nova network deployment with Tenant Network Type set to vlan.

Result:
The suggested vlan is  (e.g. 10:100) - too big.
This will be used by unexperienced admins and needs to be shrink for most setups.

Expected result:
smaller vlan range

Comment 1 Scott Seago 2014-07-29 16:39:20 UTC
Fix posted to PR at https://github.com/theforeman/staypuft/pull/244

Comment 4 Omri Hochman 2014-08-07 13:10:01 UTC
I'm working with the latest puddle and getting rhel-osp-installer-0.1.6-5.el6ost.noarch, 

form looking at the UI the caption besides nova-network VLAN value__________________ [1-4094] (e.g. 10:100)

The latest puddle do not include the fixed rhel-osp-installer version and there for - the bug should not be ON_QA.

Comment 5 Scott Seago 2014-08-07 21:38:37 UTC
I wonder if there's 0.1.x vs. 0.2.x branch confusion here? Have we built puddles for both? In any case this is, at the very least in 'post' since it's been pushed to the master branch since updating it to 'post' earlier.

Comment 6 Mike Burns 2014-08-07 21:44:54 UTC
Please check your ruby193-rubygem-staypuft build against the version in the fixed-in version field.  If you're using the puddle, you have a 0.1.x version.  This is fixed in 0.2.0.

moving back to ON_QA

Comment 7 Alexander Chuzhoy 2014-08-11 20:43:42 UTC
Verified: rhel-osp-installer-0.1.9-1.el6ost.noarch


Now it says:  (e.g. 10:15)

Comment 8 errata-xmlrpc 2014-08-21 18:06:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.