Bug 112350 - rndc dumpdb could not open dump file
rndc dumpdb could not open dump file
Status: CLOSED DUPLICATE of bug 126638
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 01:43 EST by Doug Palmer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Palmer 2003-12-18 01:43:18 EST
From Bugzilla Helper:
User-Agent: Opera/7.23 (X11; Linux i686; U)  [en]

Description of problem:
Using rndc to produce a dump of the nameserver does not produce a 
dump file.

Command (as root): rndc dumpdb

An error appears in /var/log/messages:

named[4939]: could not open dump file: permission denied



Version-Release number of selected component (if applicable):
9.2.2.P3-9

How reproducible:
Always

Steps to Reproduce:
1. Login as root
2. Enter 'rndc dumpdb'
3. tail /var/log/messages
    

Actual Results:  Nothing, other than the error message.

Expected Results:  A dump file should appear somewhere.

Additional info:
Comment 1 Daniel Walsh 2003-12-29 07:26:07 EST
The problem is that we do not want to allow named to write to the
/var/named directory, which is where the dumpfile is attempting to be
created.  You can create a subdirectory dump under /var/named or
/var/chroot/var/named and change its owner ship to named.named.  Then
modify the /etc/named.conf file to include the following option
dump-file "dump/named_dump.db";

Then it will work.

Dan
Comment 2 Doug Palmer 2003-12-29 17:28:45 EST
Since named chroots, the dump directory needs to be under
/var/named/chroot/var/named and the /etc/named.conf files also needs
to be copied to /var/named/chroot/etc

I think that this should be fixed in the named RPM and in the
configuration tools.
Comment 3 Jason Vas Dias 2004-08-04 18:24:30 EDT

*** This bug has been marked as a duplicate of 126638 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.