Bug 1123512 - [bug] clicking 3x in empty kwrite window causes segfault
Summary: [bug] clicking 3x in empty kwrite window causes segfault
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdelibs
Version: 6.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1002711 1075802 1172231 1271696
TreeView+ depends on / blocked
 
Reported: 2014-07-25 21:44 UTC by Joe Wright
Modified: 2019-09-12 07:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 19:35:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
ccpp file contents from local reproducer (2.67 MB, application/x-gzip)
2014-07-25 21:44 UTC, Joe Wright
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0744 normal SHIPPED_LIVE kdebase bug fix update 2016-05-10 22:30:08 UTC

Description Joe Wright 2014-07-25 21:44:07 UTC
Created attachment 921063 [details]
ccpp file contents from local reproducer

Description of problem:
kwrite segfaults when triple clicking on empty file

Version-Release number of selected component (if applicable):
- kdebase-4.3.4-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open kwrite
2. click 3 times rapidly (as if attempting to highlight a line)
3. crash

Actual results:
- crash

Expected results:
- nothing should happen

Additional info:
I was unable to get the debug packages for the latest version of KDE to run a backtrace. ccpp file contents attached

Does not crash as long as there is something to highlight, including alphanumeric characters and/or empty spaces/lines

Does not appear to be an issue in fedora upstream. Tested on FC19, kde 4.11.5 with no issues

Comment 6 Than Ngo 2014-10-23 15:14:10 UTC
i set the state to NEEDINFOS, it's bette to track the issue, because feedback from testing of the fix is needed.
thanks

Comment 8 Joe Wright 2014-10-23 21:57:34 UTC
Another customer reported the issue. I provided the packages to them.

I tested the package on a virtual machine of mine running RHEL 6.6 and can confirm that the package fixes the 3x click bug in kwrite for me.

Comment 17 Jan Grulich 2015-11-04 12:52:09 UTC
Fixed in kdelibs-4.3.4-24.el6.

Comment 22 errata-xmlrpc 2016-05-10 19:35:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0744.html


Note You need to log in before you can comment on or make changes to this bug.