Bug 1123531 - User root is logged in on sshd.
Summary: User root is logged in on sshd.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 00:41 UTC by Tom Horsley
Modified: 2014-08-18 22:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 22:48:09 UTC


Attachments (Terms of Use)

Description Tom Horsley 2014-07-26 00:41:45 UTC
Description of problem:

I'm not sure where sshd comes from here. In an xterm, I do this:

zooty> sudo su -l
Last login: Fri Jul 25 20:16:09 EDT 2014 on pts/0
[root@zooty ~]# exit
logout
zooty> reboot
User root is logged in on sshd.
Please retry operation after closing inhibitors and logging out other users.
Alternatively, ignore inhibitors and users with 'systemctl reboot -i'.
zooty> 

Apparently the act of doing "sudo su -l" make systemd believe it should generate the error shown above, even though I exited from that su session.


Version-Release number of selected component (if applicable):
systemd-208-20.fc20.x86_64


How reproducible:
Seems to be every time.

Steps to Reproduce:
1.see above
2.
3.

Actual results:
can't reboot anymore

Expected results:
can reboot

Additional info:
Even when I switch to root to reboot so it won't complain, it takes forever for the reboot to actually finish. It is apparently timing out on the imaginary root sshd session.

Comment 1 Lennart Poettering 2014-08-05 10:47:39 UTC
Waht's "sudo su -l" supposed to be?

You become root, and then you become root again inside of it? "We must go deeper!"

Does "sudo -s" have the same effect?

Do you have anybody else logged in at the same time if you type "w" or "who"?

Comment 2 Tom Horsley 2014-08-05 11:47:06 UTC
(In reply to Lennart Poettering from comment #1)
> Waht's "sudo su -l" supposed to be?

That gets me a shell in which root's .bash_profile has executed, setting up
PATH, aliases, etc. as root expects them so commands operate as expected.

> Does "sudo -s" have the same effect?

Don't know because I can't reproduce this now. I have gotten the newer
systemd-208-21.fc20.x86_64 since I submitted the bug, so perhaps it was
fixed by something that changed since 208-20.

> Do you have anybody else logged in at the same time if you type "w" or "who"?

Just my normal user running X. When I was experimenting with this, I rebooted several times, so someone else logging in would have needed really good timing.

Comment 3 Lennart Poettering 2014-08-18 22:48:09 UTC
OK, closing. If you can reproduce this, please reopen.


Note You need to log in before you can comment on or make changes to this bug.