Bug 1123555 - virtio-mmio is slooowwwww
Summary: virtio-mmio is slooowwwww
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2014-07-26 11:55 UTC by Richard W.M. Jones
Modified: 2015-11-04 23:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 23:55:11 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-07-26 11:55:41 UTC
Description of problem:

On x86-64 (laptop, Core i7):

virtio-serial upload rate:      200553666 bytes/sec (191 Mbytes/sec)
virtio-serial download rate:    818819252 bytes/sec (780 Mbytes/sec)
block device writes:            128171758 bytes/sec (122 Mbytes/sec)
block device reads:             135930402 bytes/sec (129 Mbytes/sec)

[I don't yet have a clear explanation for why guest->host
(download) transfers are so much faster than the other way,
but that's not important for this bug.]

On aarch64:

virtio-serial upload rate:      7273232 bytes/sec (6 Mbytes/sec)
virtio-serial download rate:    16629760 bytes/sec (15 Mbytes/sec)
block device writes:            13466009 bytes/sec (12 Mbytes/sec)
block device reads:             17699635 bytes/sec (16 Mbytes/sec)

Version-Release number of selected component (if applicable):

x86-64 test was using qemu-2.0.0-0.1.rc0.fc21.x86_64
aarch test was with upstream qemu from git

How reproducible:

100%

Steps to Reproduce:
1. I'm using this program:
https://github.com/libguestfs/libguestfs/blob/master/tests/qemu/qemu-speed-test.c

Comment 1 Paolo Bonzini 2014-12-10 11:12:52 UTC
I suspect it's not virtio-mmio, but just KVM on ARM.

Comment 2 Jaroslav Reznik 2015-03-03 16:09:15 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 Cole Robinson 2015-11-04 23:55:11 UTC
I doubt virtio-mmio is going to get any faster since all future work is looking at virtio-pci. So this bug isn't going to generate anything IMO


Note You need to log in before you can comment on or make changes to this bug.