Bug 1123558 - upgrade to 5.0.5-1 breaks _vim_files completion
Summary: upgrade to 5.0.5-1 breaks _vim_files completion
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: zsh
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 12:48 UTC by Daniel Stone
Modified: 2014-10-20 11:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 11:44:11 UTC


Attachments (Terms of Use)

Description Daniel Stone 2014-07-26 12:48:26 UTC
Since upgrading to 5.0.5-1.fc20, my _vim_files autocompletion has been broken:
nightslugs:~% vim <TAB>
_arguments:450: _vim_files: function definition file not found

Re-exec doesn't help this.

Editing /usr/share/zsh/5.0.5/functions/_vim and deleting the:
(${functions[_vim_files]}) ||
prefix before the _vim_files() { ... } definition, makes this work again for me.

(Apologies if the deleted line isn't right; I've removed it now so had to type it from memory. But it's the one that avoids redeclarations if it's already there.)

The only thing I can think of in .zsh/compinstall which would do it is:
zstyle ':completion:*:functions' ignored-patterns '_*'

Any ideas welcome ...

Comment 1 Dominic Hopf 2014-09-01 10:44:48 UTC
Can you check if the issue is still present for you using the latest Zsh 5.0.6 release? You may get it from here already:

    http://koji.fedoraproject.org/koji/buildinfo?buildID=572805

Will be available via updates-testing next days.

Comment 2 Daniel Stone 2014-10-20 11:44:11 UTC
Sorry, yes, it's worked totally fine for me for a while now. Thanks for the fix!


Note You need to log in before you can comment on or make changes to this bug.