Bug 1123566 - mate-settings-daemon crashes in a loop, hogging CPU and causing desktop redraws
Summary: mate-settings-daemon crashes in a loop, hogging CPU and causing desktop redraws
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-settings-daemon
Version: 20
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-26 16:21 UTC by Sergey Bostandzhyan
Modified: 2014-07-30 17:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 17:32:03 UTC


Attachments (Terms of Use)
Debug output of mate-settings-daemon before the crash. (28.80 KB, text/x-log)
2014-07-26 16:21 UTC, Sergey Bostandzhyan
no flags Details

Description Sergey Bostandzhyan 2014-07-26 16:21:21 UTC
Created attachment 921192 [details]
Debug output of mate-settings-daemon before the crash.

Description of problem:

At some point mate-settings-daemon started to crash in a loop, making the desktop completely unusable, everything was flickering, CPU time was hogged.

It is interesting to note that the main menu icon was repeatedly changing between the default mate symbol and the gnome "foot" icon.

I tried to start the daemon in the console to get the output (see attachment).
The command was:
/usr/libexec/mate-settings-daemon --debug --replace 2>&1 >/tmp/mate-settings-daemon.log
The daemon quickly exited with "Segmentation fault". Unfortunately I can not see any errors inside the log file.

Version-Release number of selected component (if applicable):
mate-settings-daemon-1.6.2-2.fc20.i686

At some points the crashes stopped without me doing anything, the "gnome foot" icon won and remained as the new menu icon.

How reproducible:
unclear, it just started to happen, logging out did not help i.e. problem was still there after re-login.

Comment 1 Wolfgang Ulbrich 2014-07-26 17:33:53 UTC
uhh, can you run /usr/libexec/mate-settings-daemon with gdb, see
http://fedoraproject.org/wiki/StackTraces#gdb
With the icon is weird, was there an update before the issue arrived?
Use 'yum history' for that.
Do you also have gnome or cinnamon installed?
Looks like something from gnome attacked your desktop.

Comment 2 Sergey Bostandzhyan 2014-07-26 17:43:48 UTC
gdb could be problematic because it happened on the notebook of my girlfriends mom who lives in another country, I do not have shell access there. Was already hard enough to guide her through the terminal for getting the log ;) I'll see if I can persuade her to try gdb.

Another problem is that we'd have to wait for it to happen again.

I'll ask her about yum history to see when the last update was made and if it correlates to todays crashes, generally I setup the system in the way that it will automatically check for updates everyday and apply them.

cinnamon is not installed, gnome destkop is not installed either, although gnome libs that are required to run gnome applications are present on the system.

Comment 3 Wolfgang Ulbrich 2014-07-26 17:54:43 UTC
Ok, remote debugging is a bit hard without ssh connection....
Your girlfriend's mum should try to create a new account and see if it also happens, maybe there is a config mismatch in home user folder configuration files.

Comment 4 Sergey Bostandzhyan 2014-07-27 17:42:21 UTC
Here is the result of some remote debugging efforts. We did not install -dbg packages though, she's on a slow connection.

#0  0x458c4c0b in __strcmp_ssse3 () from /lib/libc.so.6
#1  0x45b2923c in g_strcmp0 () from /lib/libglib-2.0.so.0
#2  0xb60b9aba in _pa_context_get_card_info_by_index_cb ()
   from /usr/lib/mate-settings-daemon/libmedia-keys.so
#3  0x4c62b06a in context_get_card_info_callback () from /lib/libpulse.so.0
#4  0x4c4ba8b0 in run_action () from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#5  0x4c4bacd0 in pa_pdispatch_run ()
   from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#6  0x4c61c9c5 in pstream_packet_callback () from /lib/libpulse.so.0
#7  0x4c4bf86b in do_pstream_read_write ()
   from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#8  0x4c4aa230 in callback () from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#9  0x4ab05adf in dispatch_func () from /lib/libpulse-mainloop-glib.so.0
#10 0x45b06556 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#11 0x45b06920 in g_main_context_iterate.isra () from /lib/libglib-2.0.so.0
#12 0x45b06dc3 in g_main_loop_run () from /lib/libglib-2.0.so.0
#13 0x48195700 in gtk_main () from /lib/libgtk-x11-2.0.so.0
#14 0x0804b22e in main ()

Does that help in any way?

Comment 5 Sergey Bostandzhyan 2014-07-27 17:44:03 UTC
One more addition: the locale is set to russian, so all card names are in cyrillic (as we already saw from the debug output), of course I do not know the code so I can't say if it has any influence, but pointing this out just in case.

Comment 6 Sergey Bostandzhyan 2014-07-28 08:03:11 UTC
More info:

we tried your suggestion with the new account, however the problem is present there as well. The new account is setup in English btw, so my locate related theory is probably wrong.

Any ideas what else to try? She needs the notebook for work and right now it's pretty much unusable :(

Comment 7 Kevin 2014-07-28 12:08:56 UTC
I can confirm I experienced the same issue. I rolled back the latest updates (minus some that wouldn't roll back) but the issue persists. Had to install Cinnamon. Happy to provide any information as required.

Thanks

Comment 8 Wolfgang Ulbrich 2014-07-28 16:11:32 UTC
Ok, i know what's going wrong.

#2  0xb60b9aba in _pa_context_get_card_info_by_index_cb ()
   from /usr/lib/mate-settings-daemon/libmedia-keys.so
#3  0x4c62b06a in context_get_card_info_callback () from /lib/libpulse.so.0
#4  0x4c4ba8b0 in run_action () from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#5  0x4c4bacd0 in pa_pdispatch_run ()
   from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#6  0x4c61c9c5 in pstream_packet_callback () from /lib/libpulse.so.0
#7  0x4c4bf86b in do_pstream_read_write ()
   from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#8  0x4c4aa230 in callback () from /usr/lib/pulseaudio/libpulsecommon-5.0.so
#9  0x4ab05adf in dispatch_func () from /lib/libpulse-mainloop-glib.so.0

see https://bugzilla.redhat.com/show_bug.cgi?id=1117683

You should update to mate-settings-daemon-1.6.2-3.fc20 and mate-media-1.6.1-2.fc20, both package are curently on the way to stable repo, maybe you should enable updates-testing to get them.
Pulsaudio should be pulseaudio-5.0-7.fc20.
The best is to catch this update too, https://admin.fedoraproject.org/updates/FEDORA-2014-8183/qemu-1.6.2-7.fc20,java-1.7.0-openjdk-1.7.0.65-2.5.1.3.fc20,qt-4.8.6-9.fc20.1,qt5-qtmultimedia-5.3.1-1.fc20.1,gnome-shell-3.10.4-7.fc20,gnome-settings-daemon-3.10.3-2.fc20,control-center-3.10.3-2.fc20,empathy-3.10.3-2.fc20,gstreamer1-plugins-good-1.2.4-2.fc20,speech-dispatcher-0.8-9.fc20,spice-gtk-0.23-3.fc20,sphinxtrain-1.0.8-13.fc20,guacamole-server-0.8.4-3.fc20,audacious-plugins-3.4.3-2.fc20,paprefs-0.9.10-7.fc20,fldigi-3.21.83-2.fc20,qmmp-0.7.7-1.fc20.1,mumble-1.2.6-1.fc20.1,libmikmod-3.3.6-3.fc20,minimodem-0.19-3.fc20,sidplayfp-1.2.0-2.fc20,xmp-4.0.7-2.fc20,gqrx-2.2.0-6.fc20,cinnamon-settings-daemon-2.2.4-2.fc20,cinnamon-control-center-2.2.10-1.fc20.1,cinnamon-2.2.14-5.fc20,phonon-4.7.2-1.fc20.1,qt-mobility-1.2.2-0.16.20140317git169da60c.fc20,fluidsynth-1.1.6-4.fc20,ffgtk-0.8.6-7.fc20,pulseaudio-5.0-7.fc20?_csrf_token=6b0c1c921bc4b9be1bce0ceb5d33cce245591c06

If it isn't already installed.

Comment 9 Sergey Bostandzhyan 2014-07-28 16:15:47 UTC
Cool, thank you!

Any ETA when these updates will hit stable? Remember, it's the system of my gf's mom so I do not really want to mess around with testing feeds there.

Comment 10 Wolfgang Ulbrich 2014-07-28 16:26:03 UTC
(In reply to Sergey Bostandzhyan from comment #9)
> Cool, thank you!
> 
> Any ETA when these updates will hit stable? Remember, it's the system of my
> gf's mom so I do not really want to mess around with testing feeds there.

see https://admin.fedoraproject.org/updates/search/mate?_csrf_token=6b0c1c921bc4b9be1bce0ceb5d33cce245591c06

Maybe 1 or 2 days, depends on how fast the servers in your gf's Mum country is updated.
But you can download them direcly, simple follow the link in the link from this post, which leads you to download side of koji build server.

Comment 11 Sergey Bostandzhyan 2014-07-30 16:22:55 UTC
Thanks a lot, the new update fixed the problem, it's good now.


Note You need to log in before you can comment on or make changes to this bug.