Bug 1123582 - Satellite 6 cannot install on systems with big disk space: katello-installer fails with "The installation requires at least 5G of storage"
Summary: Satellite 6 cannot install on systems with big disk space: katello-installer ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-26 21:57 UTC by Jan Hutař
Modified: 2016-04-22 16:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:24:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6823 None None None 2016-04-22 16:42:05 UTC

Description Jan Hutař 2014-07-26 21:57:18 UTC
Description of problem:
Installer complains I do not have enough free disk space - you can not install


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-7-20140723.0


How reproducible:
always


Steps to Reproduce:
1. Check you gave free disk space in TBs:
   # df -H --total
   Filesystem                              Size  Used Avail Use% Mounted on
   /dev/mapper/rhel_dell--per620--02-root   54G  2.7G   51G   6% /
   devtmpfs                                 17G     0   17G   0% /dev
   tmpfs                                    17G     0   17G   0% /dev/shm
   tmpfs                                    17G  9.4M   17G   1% /run
   tmpfs                                    17G     0   17G   0% /sys/fs/cgroup
   /dev/sda1                               521M  110M  412M  22% /boot
   /dev/mapper/rhel_dell--per620--02-home   47T   36M   47T   1% /home
   total                                    47T  2.9G   47T   1% -
1. On a system with big enough free disk space (it TB) just run:
   # katello-installer


Actual results:
# katello-installer
The installation requires at least 5G of storage.
Your system does not meet configuration criteria


Expected results:
Installation should proceed


Additional info:
I believe this is caused by this code which expects free disk space to be in gigabytes:

# rpm -qf /usr/share/katello-installer/checks/disk_size.rb
katello-installer-0.0.56-1.el7sat.noarch
# cat /usr/share/katello-installer/checks/disk_size.rb
#!/usr/bin/env ruby

SIZE = %q(The installation requires at least 5G of storage.) 

def error_exit(message, code)
  $stderr.puts message
  exit code
end

begin
    total_space = `df -H --total`.split("\n")[-1].split()[3]

    # Look for a value greater than 4GB
    error_exit(SIZE, 1) unless total_space.include?("G")
    error_exit(SIZE, 2) if total_space.gsub("G","").to_i < 5
rescue
    # Eat the exception and continue
end

Comment 3 Bryan Kearney 2014-07-29 18:50:58 UTC
Created redmine issue http://projects.theforeman.org/issues/6823 from this bug

Comment 5 Bryan Kearney 2014-08-11 20:05:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6823 has been closed
-------------
Anonymous
Applied in changeset commit:katello-installer|3c780f8f3d9673cd5e664ecf05061b81ba6e3a5c.

Comment 8 Daniel Lobato Garcia 2014-09-01 16:38:13 UTC
DEVELOPER VERIFIED: I tested this on my own computer with TBs of free space. It passes the disk size checks well. I wanted to clone the beaker job to test it again but I'm not member of the group 'satellite'.

Comment 9 Kedar Bidarkar 2014-09-02 09:09:07 UTC
Tested with TBs of storage and on Sat6-GA-snap7


Installed Packages

    candlepin-0.9.23-1.el6_5.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23-1.el6_5.noarch
    candlepin-tomcat6-0.9.23-1.el6_5.noarch
    createrepo-0.9.9-21.2.pulp.el6sat.noarch
    elasticsearch-0.90.10-6.el6sat.noarch
    katello-1.5.0-30.el6sat.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.64-1.el6sat.noarch
    katello-server-ca-1.0-1.noarch
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-4.el6sat.noarch
    pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
    pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
    pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
    pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
    pulp-rpm-plugins-2.4.1-0.6.beta.el6sat.noarch
    pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
    pulp-server-2.4.1-0.5.rc1.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.1-0.5.rc1.el6sat.noarch
    python-pulp-common-2.4.1-0.5.rc1.el6sat.noarch
    python-pulp-puppet-common-2.4.1-0.5.rc1.el6sat.noarch
    python-pulp-rpm-common-2.4.1-0.6.beta.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-86.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el6sat.noarch

Comment 10 Bryan Kearney 2014-09-11 12:24:20 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.