Bug 1123585 - [RFE] Need OSP installer to be able to support removing/replacing storage nodes
Summary: [RFE] Need OSP installer to be able to support removing/replacing storage nodes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: Installer
Assignee: Jason Guiditta
QA Contact: yeylon@redhat.com
URL: https://trello.com/c/nnwPFYrI/136-cru...
Whiteboard:
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-07-26 22:08 UTC by arkady kanevsky
Modified: 2016-04-18 06:53 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 15:02:13 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-26 22:08:06 UTC
Description of problem:
Initial ask is for Ceph block storage only.
Next is Ceph object store. (will need to file a separate bug for it).
Later it can be extended to glusterFS, and other software-define block storage. (yet another bug later)

This is to allow installer to add a node to a storage group.
This includes installing operating system, and all networks setup.
For Ceph block storage it need to include triggering ICE to add the configured node to Ceph cluster, including installing Ceph libraries, rebuilding a keyring, and updating all Ceph cluster and client nodes with new keyring. 

For node deletion consists of two parts.
One is for OSP installer removal of a node under its control.
The second is specific to the storage that is run on storage node.
For Ceph it is equivalent to a failed node, with data redistribution between remaining nodes of ceph cluster, keyring rebuilding and updating keyring on client nodes. But since node to be removed is available it is possible to expedite data redistribution movement.
In addition, an attempt to remove a node from a cluster of size 3 or less is prohibited and returns an error.
UI must be provided for node removal (this is node type independent.)

For node replacement, Installer should provide a way to specify which node in storage cluster should be replaced, it could be down already, or still active.
But new node should attain identity of replaced node, including its network connections and its IP addresses. Then ICE need to "re-install" ceph on new node.

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Mike Burns 2014-10-01 17:36:29 UTC
removing from A2.  Adding should work correctly in the current version.  Removing/Replacing is a future feature.

Comment 5 arkady kanevsky 2014-10-21 20:45:19 UTC
Do we need a separate bug for OSP6 Installer? or will it automatically make it if its in A3?

Comment 6 Mike Burns 2014-10-23 12:59:44 UTC
(In reply to arkady kanevsky from comment #5)
> Do we need a separate bug for OSP6 Installer? or will it automatically make
> it if its in A3?

This was incorrectly targeted at A3.  It's a target for sometime in the RHEL-OSP 6 timeframe.

As mentioned, adding new nodes should work now.  Removing/Replacing will come in a later release.

Comment 7 arkady kanevsky 2014-10-23 13:09:59 UTC
SHould split this bug into 2. One for add, this bug, that we can close, and another one for deletion and replacement for the future.

Comment 8 Mike Burns 2014-10-23 13:20:21 UTC
No need to split.  I updated the summary to remove any mention of adding.  This bug is now for removing/replacing storage nodes.

Comment 11 Jason Guiditta 2016-04-04 15:02:13 UTC
we are no longer implementing new features for ofi.


Note You need to log in before you can comment on or make changes to this bug.