Bug 1123589 - terrible stuttering after upgrading to pulseaudio-libs-5.0-7
Summary: terrible stuttering after upgrading to pulseaudio-libs-5.0-7
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 00:21 UTC by John Schmitt
Modified: 2015-06-29 21:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 21:46:52 UTC


Attachments (Terms of Use)
how to set up wine to play borderlands 2 (3.62 KB, text/plain)
2014-08-26 04:28 UTC, John Schmitt
no flags Details

Description John Schmitt 2014-07-27 00:21:41 UTC
Last night I upgraded my system.  Before this update, everything worked fine.  This is a fresh install of Fedora 20 (that is, this instance is not an upgrade from previous versions of Fedora) which I keep updating regularly.

Last night's upgrade included a revision to pulseaudio:

$ sudo cat /var/log/yum.log | grep 'Jul 26' | grep -i pulse
Jul 26 01:11:37 Updated: pulseaudio-libs-5.0-7.fc20.x86_64
Jul 26 01:11:38 Updated: pulseaudio-libs-glib2-5.0-7.fc20.x86_64
Jul 26 01:11:50 Updated: pulseaudio-5.0-7.fc20.x86_64
Jul 26 01:12:19 Updated: pulseaudio-module-gconf-5.0-7.fc20.x86_64
Jul 26 01:12:19 Updated: pulseaudio-utils-5.0-7.fc20.x86_64
Jul 26 01:12:19 Updated: pulseaudio-module-x11-5.0-7.fc20.x86_64
Jul 26 01:14:47 Updated: pulseaudio-libs-5.0-7.fc20.i686
Jul 26 01:15:06 Updated: kde-settings-pulseaudio-20-16.fc20.noarch
Jul 26 01:15:39 Updated: pulseaudio-module-bluetooth-5.0-7.fc20.x86_64

This has caused terrible stuttering from borderlands 2 under wine and also youtube with chromium.  

I had it all working for a short while by trying a few things:

- unplugging my USB headphones and then plugging them back in
- restarting pulseaudio
- using pavucontrol to point output to the built-in and then the null device
- adding tsched=0 to default.conf, e.g. load-module module-udev-detect tsched=0

I cannot get borderlands 2 to work any more.  Any order of the things I tried has not helped.  The fix is not reproducible.

The symptoms are that borderlands 2 plays slowly and any sound it makes stutters and echos terribly.  The game is unusable.  Sometimes I can make youtube work again, but I have not yet been able to determine a reproducible set of steps that will fix it.

Comment 1 John Schmitt 2014-07-27 23:27:05 UTC
It seems that most of the time I can fix youtube issues by simply unplugging the headphones, waiting a second or two and then plugging it back in.

Fixing Borderlands 2 (and probably other wine games) is a bit tricky.  I have to start the game without the headphones plugged in.  I have to let the opening sequences play.  They always play with audio, and the audio during the opening sequences always plays properly when I have my headphones plugged in.  I wait until the maps are loaded and my character is in game and then plug in my headphones.  This seems reproducible.

Comment 2 John Schmitt 2014-07-27 23:34:31 UTC
I've seen a new symptom.  When Skype pops up its alert sounds (e.g. an incoming message was received), very often Borderlands 2 will hard hang at the very second the Skype sound plays.  

Skype also has unexplained behavior after this occurs.  It no longer transmits or receives new messages.  Quitting skype seems to work, i.e. the GUI windows disappear normally, but when I view the process list from htop, skype is still running and seems to require a SIGTERM before it will actually quit.

Comment 3 Rex Dieter 2014-07-30 00:12:06 UTC
Wrt wine, please try this update:
https://admin.fedoraproject.org/updates/FEDORA-2014-8416

Comment 4 Rex Dieter 2014-07-30 00:13:36 UTC
Otherwise, do make sure you've restarted your session since installing the newer pulseaudio (and associated packages) from,
https://admin.fedoraproject.org/updates/FEDORA-2014-8183

Comment 5 John Schmitt 2014-08-24 22:06:45 UTC
The machone on which I see this is always kept up to date.  I've reproduced this dozens of times now with many reboot cycles.  There has even been a kernel update since I reported this.  

I have never installed pipelight since none of the applications I run need it.  Is there any way pipelight could make a difference?

This is my routine now if I want to play borderlands 2:

1. Unplug my USB headphones.

2. Launch steam under wine and them borderlands 2 under wine.  (I'm trying to be clear that I'm not running the native Linux version of steam at this time)

3. Wait for the loading screens to finish and load my character and shoot or run or do something that will generate sounds.  The loading screens make all sounds of sounds and they always work even if I don't follow these steps.

4. Plug in USB headphones.

5. Play!

There do not seem to be any packages in testing which I could test:

$ sudo yum --enablerepo=updates-testing upgrade wine\* pulse\*
Loaded plugins: changelog, langpacks, list-data, refresh-packagekit, show-leaves
No packages marked for update

Comment 6 John Schmitt 2014-08-24 22:09:13 UTC
I forgot to mention that the interaction with skype is still the same.  When skype plays an alert sound while I'm playing borderlands 2, borderlands 2 will hard hang.

Regular voice chat on skype still works.

Comment 7 Rex Dieter 2014-08-25 15:42:30 UTC
https://admin.fedoraproject.org/updates/FEDORA-2014-8416

the important one there was wine, but that's already gone into stable updates now.

Comment 8 John Schmitt 2014-08-25 16:47:05 UTC
Would it help if I included a shell script that will set up wine for borderlands 2?  Since it took me a few tries to get my wine instance configured correctly, I ended up creating this script so I would have to remember how I created it.  Borderlands 2 is often on sale now for $10 or so on steam.

Comment 9 Rex Dieter 2014-08-25 17:23:30 UTC
Couldn't hurt, thanks.

Comment 10 John Schmitt 2014-08-26 04:28:25 UTC
Created attachment 930731 [details]
how to set up wine to play borderlands 2

This is a bash script I use to install and launch borderlands 2.  It's an ongoing project that I kludge further whenever it's needed.  As you'll see, it is way overdue for a clean up.


1. Create a directory from which to run this.  I use ~/wineapps3 and place this script in it.

2. Install winetricks somewhere in your $PATH.

3. Download the steam installer for Windows.  It was called SteamSetup.exe when I downloaded it.  Put it in ~/wineapps/cache

4. cd ~/wineapps3; ./b2

5. Follow prompts and accept the defaults.  They're all pretty obvious.

6. When steam first runs, the fonts might not be visible.  The -no-dwrite works around the bug that causes this bug.  Quit and run ./b2 again.  

7. Downloading steam and borderlands 2 takes time.  Allow it to finish.  Click on Install for borderlands 2 in steam's library.

If a disruption occurs, simply lauch ./b2 again.

Once all this is done, simply launching ./b2 will launch borderlands 2.

Borderlands 2 will not run properly on my machine if I simply launch it from steam the way I would if I were running windows.  

The only reason I run nvidia-settings is to select a monitor to be primary.  This obviously won't work for  ATI and Intel setups so feel free to comment out / delete that line.

If someone wants live interactive help, meet me on IRC or some other IM tool.

Comment 11 John Schmitt 2014-08-26 04:31:14 UTC
I just noticed that I have my $HOME directory hard-coded in a few places.

Comment 12 Fedora End Of Life 2015-05-29 12:28:59 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 13 Fedora End Of Life 2015-06-29 21:46:52 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.