Bug 1123648 - gcc 4.9 but libasan 4.8
Summary: gcc 4.9 but libasan 4.8
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 15:08 UTC by Maxim Prohorenko
Modified: 2014-09-01 13:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-01 13:10:19 UTC


Attachments (Terms of Use)

Description Maxim Prohorenko 2014-07-27 15:08:49 UTC
Description of problem:
/usr/bin/ld: cannot find /usr/lib64/libasan.so.1.0.0

only /usr/lib64/libasan.so.0.0.0 presents

Version-Release number of selected component (if applicable):
gcc --version
gcc (GCC) 4.9.0 20140409
libasan 4.8.3-1.fc20

How reproducible:


Steps to Reproduce:
1. add -fsanitize=address
2. compile & link
3. error

Actual results:
/usr/bin/ld: cannot find /usr/lib64/libasan.so.1.0.0

Expected results:
link ok

Additional info:
dnf --enablerepo=rawhide update libasan
solve my problem

Comment 1 Jakub Jelinek 2014-09-01 13:10:19 UTC
gcc intentionally doesn't have a Requires: libasan-devel, because we don't want to force everybody to install the library just because a small percentage of users will want to use -fsanitize=address.
Thus IMHO NOTABUG, don't update just selected components, but the whole system, or deal with any issues selective updates cause.


Note You need to log in before you can comment on or make changes to this bug.