Bug 1123651 - upgrade requested when sync is attempted
Summary: upgrade requested when sync is attempted
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anki
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 16:49 UTC by Petr Machata
Modified: 2015-05-05 01:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 07:25:12 UTC


Attachments (Terms of Use)

Description Petr Machata 2014-07-27 16:49:24 UTC
Description of problem:
ankiweb has been complaining about 2.0.26, requesting that Anki should be "upgraded to the latest version".  Sync doesn't work at all with 2.0.26.  Per the news, 2.0.27 has seen a rewrite of media-syncing algorithms, presumably that's what it's about.  Anyway, rebasing to 2.0.27 works for me.

Version-Release number of selected component (if applicable):
2.0.26-3, before that 2.0.22-something I think.

How reproducible:
consistently.

Steps to Reproduce:
1. Attempt to sync a deck.
2.
3.

Actual results:
A request to upgrade.

Expected results:
It just works.

Additional info:
Update to 2.0.28 fixes this problem for me.

Comment 1 Piotr Rafa 2014-07-27 20:47:09 UTC
Confirmed, syncing does not work anymore with Anki 2.0.26 or lower.

Switching to version 2.0.28 installed from source .tgz means all of the plugins have to be re-installed maually as well.

Comment 2 Christian Krause 2014-07-31 07:25:12 UTC
I've pushed out new anki packages for all Fedora releases.

rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=549250


Note You need to log in before you can comment on or make changes to this bug.