Bug 1123668 - Activation keys attached to multiple pools of the same time consume all the pools (instead of choosing the best fit)
Summary: Activation keys attached to multiple pools of the same time consume all the p...
Keywords:
Status: CLOSED DUPLICATE of bug 1126924
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 21:36 UTC by Ivan Necas
Modified: 2017-02-23 21:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 07:05:35 UTC


Attachments (Terms of Use)

Description Ivan Necas 2014-07-27 21:36:22 UTC
Description of problem:
I have more pools available for one subscription (at least the physical and the virtual subscriptions). I want an activation key, that I can attach all the pools to the product and it will choose one of them (ideally, preferring the virtual subscriptions when available and fitting the virtual machine)


Steps to Reproduce:
1. attach some pools to the manifest
2. attach some more pools to the manifest
3. attach even more pools to the manifest
4. import the manifest (you will see bunch of pools there)
5. subscribe a physical host with virt-who running to the pool (causing
another set of pools to be available)
6. create a guest host on the physical one
7. create an activation key, attach all the pools of the product
8. subscribe the guest host with that activation key

Actual results:
Every pool gets one subscription consumed

Expected results:
1 subscription from each pool was consumed, ideally the virtual one preferred over the physical one

Additional info:

Comment 1 RHEL Product and Program Management 2014-07-27 21:43:32 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ivan Necas 2014-08-06 07:05:35 UTC

*** This bug has been marked as a duplicate of bug 1126924 ***


Note You need to log in before you can comment on or make changes to this bug.