Bug 1123682 - [abrt] efibootmgr: unparse_media_hard_drive_path(): efibootmgr killed by SIGABRT
Summary: [abrt] efibootmgr: unparse_media_hard_drive_path(): efibootmgr killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: efibootmgr
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ceab15e7cf7688a60e6568c8a95...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 23:01 UTC by Moez Roy
Modified: 2014-11-01 01:31 UTC (History)
6 users (show)

Fixed In Version: efibootmgr-0.11.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-28 06:37:51 UTC


Attachments (Terms of Use)
File: backtrace (14.64 KB, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: cgroup (172 bytes, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: core_backtrace (1.76 KB, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: dso_list (664 bytes, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: environ (2.76 KB, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: limits (1.29 KB, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: maps (3.54 KB, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: open_fds (138 bytes, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: proc_pid_status (909 bytes, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details
File: var_log_messages (350 bytes, text/plain)
2014-07-27 23:01 UTC, Moez Roy
no flags Details

Description Moez Roy 2014-07-27 23:01:32 UTC
Version-Release number of selected component:
efibootmgr-0.7.0-3.fc20

Additional info:
reporter:       libreport-2.2.2
backtrace_rating: 4
cmdline:        efibootmgr -v
crash_function: unparse_media_hard_drive_path
executable:     /usr/sbin/efibootmgr
kernel:         3.14.9-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (4 frames)
 #5 unparse_media_hard_drive_path at src/lib/unparse_path.c:349
 #6 unparse_media_path at src/lib/unparse_path.c:368
 #7 unparse_path at src/lib/unparse_path.c:478
 #8 show_boot_vars at src/efibootmgr/efibootmgr.c:680

Comment 1 Moez Roy 2014-07-27 23:01:35 UTC
Created attachment 921582 [details]
File: backtrace

Comment 2 Moez Roy 2014-07-27 23:01:35 UTC
Created attachment 921583 [details]
File: cgroup

Comment 3 Moez Roy 2014-07-27 23:01:36 UTC
Created attachment 921584 [details]
File: core_backtrace

Comment 4 Moez Roy 2014-07-27 23:01:37 UTC
Created attachment 921585 [details]
File: dso_list

Comment 5 Moez Roy 2014-07-27 23:01:37 UTC
Created attachment 921586 [details]
File: environ

Comment 6 Moez Roy 2014-07-27 23:01:38 UTC
Created attachment 921587 [details]
File: limits

Comment 7 Moez Roy 2014-07-27 23:01:39 UTC
Created attachment 921588 [details]
File: maps

Comment 8 Moez Roy 2014-07-27 23:01:39 UTC
Created attachment 921589 [details]
File: open_fds

Comment 9 Moez Roy 2014-07-27 23:01:40 UTC
Created attachment 921590 [details]
File: proc_pid_status

Comment 10 Moez Roy 2014-07-27 23:01:41 UTC
Created attachment 921591 [details]
File: var_log_messages

Comment 11 Elliott Sales de Andrade 2014-08-07 07:12:27 UTC
Another user experienced a similar problem:

Run efibootmgr -v

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        efibootmgr -v
crash_function: unparse_media_hard_drive_path
executable:     /usr/sbin/efibootmgr
kernel:         3.15.6-200.fc20.x86_64
package:        efibootmgr-0.7.0-3.fc20
reason:         efibootmgr killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Kamil Páral 2014-10-18 22:11:15 UTC
Another user experienced a similar problem:

Simply executed 'sudo efibootmgr -v'. Without '-v', it does not crash. The command used to work a few weeks ago just fine, and I haven't made any UEFI changes since then.

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        efibootmgr -v
crash_function: unparse_media_hard_drive_path
executable:     /usr/sbin/efibootmgr
kernel:         3.16.3-200.fc20.x86_64
package:        efibootmgr-0.7.0-3.fc20
reason:         efibootmgr killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0

Comment 13 Kamil Páral 2014-10-18 22:18:04 UTC
Updated FAF report:
https://retrace.fedoraproject.org/faf/reports/455801/

Comment 14 Kamil Páral 2014-10-18 22:18:55 UTC
Might be caused by https://admin.fedoraproject.org/updates/FEDORA-2014-12419/efivar-0.13-1.fc20 -- that's what I updated a short time ago.

Comment 15 Peter Jones 2014-10-20 16:39:19 UTC
No, it's not caused by that - it's a legitimate efibootmgr bug, and you're just getting a slightly different memory map when the different library is loaded, and that's causing it to fault instead of continue silently in error.

Comment 16 Fedora Update System 2014-10-20 16:40:01 UTC
efibootmgr-0.10.0-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/efibootmgr-0.10.0-1.fc21

Comment 17 Fedora Update System 2014-10-20 16:41:04 UTC
efibootmgr-0.10.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/efibootmgr-0.10.0-1.fc20

Comment 18 Fedora Update System 2014-10-20 19:04:41 UTC
efibootmgr-0.10.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/efibootmgr-0.10.0-1.fc19

Comment 19 Fedora Update System 2014-10-21 10:27:17 UTC
Package efibootmgr-0.10.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing efibootmgr-0.10.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13354/efibootmgr-0.10.0-1.fc20
then log in and leave karma (feedback).

Comment 20 Kamil Páral 2014-10-21 20:29:18 UTC
Thanks, the new build fixes the crash for me.

Comment 21 Fedora Update System 2014-10-28 06:37:51 UTC
efibootmgr-0.11.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-11-01 01:31:47 UTC
efibootmgr-0.11.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.