Bug 1123685 - RHEV compute resource without quota fails on creating a vm with "Failed to create a compute" "Internal Engine Error"
Summary: RHEV compute resource without quota fails on creating a vm with "Failed to cr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Martin Korbel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 23:20 UTC by Ivan Necas
Modified: 2016-04-22 16:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:18:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6816 None None None 2016-04-22 16:56:39 UTC

Description Ivan Necas 2014-07-27 23:20:00 UTC
Steps to Reproduce:
1. create compute resource on rhev with a blank quota
2. provision a host on that compute resource

Actual results:
Provisioning fails with "Failed to create a compute" "Internal Engine Error"

Expected results:
Provisioning succeeds

Additional info:

RHEV 3.4.1-0.30.el6ev

Additional debugging pointed to the quota parameter not being accepted, when set to "", switching to nil seemed to fix the issue

Comment 1 RHEL Product and Program Management 2014-07-27 23:23:34 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ivan Necas 2014-07-29 13:58:20 UTC
Created redmine issue http://projects.theforeman.org/issues/6816 from this bug

Comment 4 Bryan Kearney 2014-07-31 14:04:43 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6816 has been closed
-------------
Ivan Necas
Applied in changeset commit:0809c9aeb0ae96cfbe2fc2b7c842ac376c8ebb91.

Comment 7 Martin Korbel 2014-09-08 04:47:31 UTC
Verified on Satellite-6.0.4-RHEL-6-20140829.0.

Comment 8 Bryan Kearney 2014-09-11 12:18:50 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.