Bug 1123723 - Virt-who failed to run at hyperv mode and esx mode
Summary: Virt-who failed to run at hyperv mode and esx mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.6
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 06:32 UTC by Liushihui
Modified: 2016-12-01 00:33 UTC (History)
4 users (show)

Fixed In Version: virt-who-0.10-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:13:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1513 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2014-10-14 01:22:23 UTC

Description Liushihui 2014-07-28 06:32:41 UTC
Description of problem:
Configure virt-who run at hyperv mode or esx mode, then run virt-who, it will failed to connect with subscription-manager

Version-Release number of selected component (if applicable):
subscription-manager-1.12.4-1.el6.x86_64
python-rhsm-1.12.4-1.el6.x86_64
virt-who-0.10-3.el6.noarch
katello-headpin-1.4.3.26-1.el6sam_splice.noarch
candlepin-0.9.6.4-1.el6sam.noarch

How reproducible:
Always

Steps to Reproduce:
1. Register system to SAM server.
2. Configure virt-who run at hyperv mode 
VIRTWHO_DEBUG=1
VIRTWHO_BACKGROUND=1
VIRTWHO_INTERVAL=5
VIRTWHO_HYPERV=1
VIRTWHO_HYPERV_OWNER=ACME_Corporation
VIRTWHO_HYPERV_ENV=Library
VIRTWHO_HYPERV_SERVER=10.66.128.173
VIRTWHO_HYPERV_USERNAME=administrator
VIRTWHO_HYPERV_PASSWORD=qwer1234P
3. Restart virt-who service
4. Check the virt-who log at /var/log/rhsm/rhsm.log

Actual results:
virt-who failed to send host/guest associate to SAM Server.
In the virt-who log ,it will pop up error message as the following:
2014-07-28 14:16:00,088 [INFO]  @virtwho.py:442 - Using virt-who configuration: virt-who
2014-07-28 14:16:00,088 [DEBUG]  @virtwho.py:170 - Starting infinite loop with 5 seconds interval
2014-07-28 14:16:00,219 [DEBUG]  @hyperv.py:208 - Hyper-V url: http://10.66.128.173:5985/wsman
2014-07-28 14:16:00,221 [DEBUG]  @hyperv.py:258 - Using NTLM authentication
2014-07-28 14:16:00,237 [DEBUG]  @hyperv.py:285 - NTLM authentication successful
2014-07-28 14:16:01,345 [ERROR]  @virtwho.py:133 - Error in communication with subscription manager, trying to recover:
Traceback (most recent call last):
  File "/usr/share/virt-who/virtwho.py", line 125, in _send
    self._sendGuests(config, virtualGuests)
  File "/usr/share/virt-who/virtwho.py", line 154, in _sendGuests
    result = manager.hypervisorCheckIn(config, virtualGuests)
TypeError: hypervisorCheckIn() takes at least 4 arguments (3 given)

Expected results:
virt-who should send host/guest associate to SAM server, it also should display correct host/guest associate in the virt-who log.

Additional info:
It has the same problem when run virt-who at esx mode.

Comment 2 Radek Novacek 2014-07-29 07:28:41 UTC
This issue has been fixed upstream:

https://git.fedorahosted.org/cgit/virt-who.git/commit/?id=e348e0328fd01abbd608f51e25a7808bd77ecbdc

Comment 3 Radek Novacek 2014-07-29 07:53:34 UTC
Fixed in virt-who-0.10-4.el6.

Comment 5 Liushihui 2014-08-01 08:27:06 UTC
Verified on virt-who-0.10-4.el6.noarch

Comment 6 errata-xmlrpc 2014-10-14 07:13:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1513.html


Note You need to log in before you can comment on or make changes to this bug.