Bug 1123743 - Unnecessary message show up while creating app with region when server has no regions
Summary: Unnecessary message show up while creating app with region when server has no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: libra bugs
URL:
Whiteboard:
Depends On: 1122413
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 07:27 UTC by XiuJuan Wang
Modified: 2014-08-26 13:53 UTC (History)
8 users (show)

Fixed In Version: rubygem-openshift-origin-controller-1.23.10.8-1.el6op
Doc Type: Bug Fix
Doc Text:
If regions did not exist in an OpenShift Enterprise environment, a confusing error message was displayed to users after creating an application. This was due to a bug in the broker's controller library. This bug fix updates the controller logic and now the broker checks to see if regions exist before displaying the error.
Clone Of: 1122413
Environment:
Last Closed: 2014-08-26 13:53:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1095 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.1.5 bug fix and enhancement update 2014-08-26 17:51:34 UTC

Description XiuJuan Wang 2014-07-28 07:27:20 UTC
+++ This bug was initially created as a clone of Bug #1122413 +++

Description of problem:
Unnecessary message "Available regions are" show up while creating app with region when server has no regions
# rhc app create app php-5.4 --region region --no-git 
Application Options
-------------------
Domain:     wjiang
Cartridges: php-5.4
Gear Size:  default
Scaling:    no
Region:     region

Creating application 'app' ... Could not find region 'region'.  Available regions are 


Version-Release number of selected component (if applicable):
fork_ami_origin_ui_186_1229
rhc build from fork_ami_origin_ui_186_1229

How reproducible:
always

Steps to Reproduce:
1. Create app with region when server have no regions
2.
3.

Actual results:
# rhc app create app php-5.4 --region region --no-git 
Application Options
-------------------
Domain:     wjiang
Cartridges: php-5.4
Gear Size:  default
Scaling:    no
Region:     region

Creating application 'app' ... Could not find region 'region'.  Available regions are 

Expected results:
The unnecessary message shouldn't show up.

Additional info:

--- Additional comment from Fabiano Franz on 2014-07-23 14:56:43 EDT ---

Fixed in https://github.com/openshift/origin-server/pull/5644

--- Additional comment from openshift-github-bot on 2014-07-23 16:34:10 EDT ---

Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/fc3f0ed5a6bc83cebe11f10f68e16a305c5e7cea
Bug 1122413 - handle server without explicit regions

--- Additional comment from weiwei jiang on 2014-07-24 01:29:36 EDT ---

Checked with devenv_5003, and the issue can not reproduce, So verify this.

Comment 2 Brenton Leanhardt 2014-08-01 14:22:26 UTC
Upstream commit:

commit fc3f0ed5a6bc83cebe11f10f68e16a305c5e7cea
Author: fabianofranz <contact@fabianofranz.com>
Date:   Wed Jul 23 12:39:52 2014 -0300

    Bug 1122413 - handle server without explicit regions

Comment 5 XiuJuan Wang 2014-08-04 05:38:23 UTC
Verified and pass on puddle-2-1-2014-08-01

Creating app with region when server has no regions,the message "Server does not support explicit regions." will show up.

Comment 7 errata-xmlrpc 2014-08-26 13:53:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1095.html


Note You need to log in before you can comment on or make changes to this bug.