Bug 1123758 - [PATCH] rpmdb often gets corrupted upon concurrent access due to a race in CDB
Summary: [PATCH] rpmdb often gets corrupted upon concurrent access due to a race in CDB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libdb
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Honza Horak
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On: 1634487 1099509 1616259
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 08:05 UTC by Jan Kurik
Modified: 2018-10-01 05:53 UTC (History)
12 users (show)

Fixed In Version: libdb-5.3.21-17.el7_0.1
Doc Type: Bug Fix
Doc Text:
Previously, a race condition could occur in the Berkeley DB Concurrent Data Store, which corrupted to the RPM database (RPMDB). After this update, process IDs during file transactions are more thoroughly tested. As a result, the race condition and the consequent RPMDB corruption no longer occur.
Clone Of: 1099509
Environment:
Last Closed: 2014-08-06 15:29:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1018 normal SHIPPED_LIVE libdb bug fix update 2014-08-06 19:29:25 UTC

Description Jan Kurik 2014-07-28 08:05:14 UTC
This bug has been copied from bug #1099509 and has been proposed
to be backported to 7.0 z-stream (EUS).

Comment 5 Branislav Blaškovič 2014-07-31 12:10:47 UTC
I am not able to reproduce this issue with attached reproducer BZ#1099509#c13.
    libdb-5.3.21-17.el7.x86_64

Running test.sh or rpmtest.sh just write `date` and nothing else - it just hangs there.

Am I doing something wrong?

Comment 10 errata-xmlrpc 2014-08-06 15:29:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1018.html


Note You need to log in before you can comment on or make changes to this bug.