Bug 1123768 - mem_acct : Check return value of xlator_mem_acct_init()
Summary: mem_acct : Check return value of xlator_mem_acct_init()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 08:33 UTC by Humble Chirammal
Modified: 2015-12-01 16:45 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Humble Chirammal 2014-07-28 08:33:08 UTC
Description of problem:


Glusterfs code does not check  xlator_mem_acct_init()
return in some places, thus fails to capture wrong memory accounting
initialization. 

Version-Release number of selected component (if applicable):


GlusterFS 3.5

How reproducible:

N/A

Steps to Reproduce:

N/A

Actual results:


Expected results:

It should check the return for failures/success.

Comment 1 Anand Avati 2014-08-06 11:31:25 UTC
REVIEW: http://review.gluster.org/7728 (mem_acct : Check return value of xlator_mem_acct_init()) posted (#8) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 2 Anand Avati 2014-08-06 11:35:47 UTC
REVIEW: http://review.gluster.org/7728 (mem_acct : Check return value of xlator_mem_acct_init()) posted (#9) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 3 Anand Avati 2014-09-19 09:07:08 UTC
REVIEW: http://review.gluster.org/7728 (mem_acct : Check return value of xlator_mem_acct_init()) posted (#10) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 4 Anand Avati 2014-09-19 09:20:51 UTC
REVIEW: http://review.gluster.org/7728 (mem_acct : Check return value of xlator_mem_acct_init()) posted (#11) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 5 Anand Avati 2014-11-12 09:32:41 UTC
REVIEW: http://review.gluster.org/7728 (mem_acct : Check return value of xlator_mem_acct_init().) posted (#12) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

Comment 6 Anand Avati 2014-11-15 18:13:16 UTC
COMMIT: http://review.gluster.org/7728 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 656711d935000c161012c25340dbd65a59999dc3
Author: Humble Chirammal <hchiramm@redhat.com>
Date:   Fri May 9 15:30:04 2014 +0530

    mem_acct : Check return value of xlator_mem_acct_init().
    
    some code does not check xlator_mem_acct_init()
    return, thus fails to capture wrong memory accounting
    initialization. This patch fix the same.
    
    Change-Id: I01eab19d6cef472afd850b0f964132c01523492a
    BUG: 1123768
    Signed-off-by: Humble Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/7728
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 7 Niels de Vos 2015-05-14 17:26:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:35:30 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:37:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:42:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.