Bug 1123770 - hwcert 1.7 fails to detect the Hyper-V video device or multiple scsi disks attached in Gen2 VM
Summary: hwcert 1.7 fails to detect the Hyper-V video device or multiple scsi disks at...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.7.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 08:43 UTC by MS OSTC SH
Modified: 2015-07-13 14:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-13 14:35:35 UTC


Attachments (Terms of Use)
Devices (39.30 KB, image/png)
2014-07-28 08:43 UTC, MS OSTC SH
no flags Details
local test plan (27.31 KB, image/png)
2014-07-28 08:44 UTC, MS OSTC SH
no flags Details

Description MS OSTC SH 2014-07-28 08:43:35 UTC
Created attachment 921724 [details]
Devices

Description of problem:
In Generation 2 VMs, run the hwcert suite, it can't detect the video device, so video is not listed in the local test plan. If multiple scsi disks are attached, they're attached to the same scsi controller, the hwcert suite can only detect the first storage device, others are not listed in the local test plan.

How reproducible:
100%

Steps to Reproduce:
1. On a Windows Server 2012R2 host, create a Generation 2 VM, install Rhel7 and all packages required for certification
2. Run hwcert
3. In the generated local test plan, video is not listed, only one scsi disk is listed when multiple scsi disks are attached

Expected results:
video and multiple scsi disks should be listed in the local test plan

Additional info:
In Generation 2 VM, pci bus is removed. The video device is under /sys/devices/LNXSYSTM:00/device:00/ACPI0004:00/VMBUS:00/vmbus_0_6/graphics/fb0.
If multiple scsi disks are attached, they're all under /sys/devices/LNXSYSTEM:00/device:00/ACPI0004:00/VMBUS:00/vmbus_0_4/host0

Comment 1 MS OSTC SH 2014-07-28 08:44:14 UTC
Created attachment 921725 [details]
local test plan

Comment 2 brose 2015-07-13 14:35:35 UTC
Closing as hwcert-client is obsolete.
Please use redhat-certification-hardware instead.


Note You need to log in before you can comment on or make changes to this bug.