Bug 1123793 - Wrong crashkernel calculations
Summary: Wrong crashkernel calculations
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide
Version: 5.10
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Miroslav Svoboda
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 09:22 UTC by Lukas Herbolt
Modified: 2015-10-06 02:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-12 14:32:45 UTC


Attachments (Terms of Use)

Description Lukas Herbolt 2014-07-28 09:22:25 UTC
Description of problem:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/s1-kdump-configuration.html#s2-kdump-configuration-firstboot

The Important box contains:
---
Unless the system has enough memory, the Kdump page will not be available. For information on minimum memory requirements, refer to the Red Hat Enterprise Linux comparison chart. When the kdump crash recovery is enabled, the minimum memory requirements increase by the amount of memory reserved for it. This value is determined by the user and on x86, AMD64, and Intel 64 architectures, it defaults to 128 MB plus 64 MB for each TB of physical memory (that is, a total of 192 MB for a system with 1 TB of physical memory).
---

Unless the system has enough memory, the Kdump page will not be available. For information on minimum memory requirements, refer to the Red Hat Enterprise Linux comparison chart. When the kdump crash recovery is enabled, the minimum memory requirements increase by the amount of memory reserved for it. This value is determined by the user and on x86, AMD64, and Intel 64 architectures, it defaults to 128 MB plus 64 MB for each GB of physical memory (appropriate example ).

In RHEL5 the size of crash is calculated in steps GB physical RAM and not in TB.

See: - https://access.redhat.com/solutions/106193

Comment 1 Jaromir Hradilek 2014-07-28 11:31:49 UTC
Thank you very much for taking the time to report this issue, Lukas.

Comment 2 Miroslav Svoboda 2014-09-12 14:32:45 UTC
(In reply to Lukas Herbolt from comment #0)
> Description of problem:
> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/
> html/Deployment_Guide/s1-kdump-configuration.html#s2-kdump-configuration-
> firstboot
> 
> The Important box contains:
> ---
> Unless the system has enough memory, the Kdump page will not be available.
> For information on minimum memory requirements, refer to the Red Hat
> Enterprise Linux comparison chart. When the kdump crash recovery is enabled,
> the minimum memory requirements increase by the amount of memory reserved
> for it. This value is determined by the user and on x86, AMD64, and Intel 64
> architectures, it defaults to 128 MB plus 64 MB for each TB of physical
> memory (that is, a total of 192 MB for a system with 1 TB of physical
> memory).
> ---
> 
> Unless the system has enough memory, the Kdump page will not be available.
> For information on minimum memory requirements, refer to the Red Hat
> Enterprise Linux comparison chart. When the kdump crash recovery is enabled,
> the minimum memory requirements increase by the amount of memory reserved
> for it. This value is determined by the user and on x86, AMD64, and Intel 64
> architectures, it defaults to 128 MB plus 64 MB for each GB of physical
> memory (appropriate example ).
> 
> In RHEL5 the size of crash is calculated in steps GB physical RAM and not in
> TB.
> 
> See: - https://access.redhat.com/solutions/106193

Hi Lukas,

I have discussed your report with the responsible kexec/kdump developer, Baoquan He (bhe@redhat.com), who confirmed that this is not a bug and our documentation describes correct default kdump behavior.

The statement that the memory increment is to be 64 MB per each TB of physical memory is correct. That's because normally the formula for calculating the minimum reserved memory is the following:

reserved memory = base memory + 2 bits per each 4 KB of physical memory

Given this information, I'm closing this BZ as NOTABUG.

Cheers,
Mirek


Note You need to log in before you can comment on or make changes to this bug.