Bug 1123816 - [barrier] Barrier error messages needs betterment
Summary: [barrier] Barrier error messages needs betterment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 10:31 UTC by Atin Mukherjee
Modified: 2018-08-29 03:37 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:37:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2014-07-28 10:31:44 UTC
Description of problem:

When user tries to enable/disable barrier on a volume where barrier is already enabled/disabled a error messsage is thrown saying "Failed to reconfigure barrier". A better message should be "Barrier is already enabled" or "Barrier is already disabled".

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1.gluster volume barrier vol-name enable
2.gluster volume barrier vol-name enable


Actual results:
volume barrier: command unsuccessful : Failed to reconfigure barrier.

Expected results:
volume barrier: command unsuccessful : Barrier is already enabled

Additional info:

Comment 1 Anand Avati 2014-07-28 10:34:52 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Anand Avati 2014-07-30 07:23:12 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Anand Avati 2014-07-30 07:47:59 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Anand Avati 2014-08-26 11:08:53 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Anand Avati 2015-03-30 05:35:04 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Anand Avati 2015-07-13 04:58:42 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 7 Vijay Bellur 2015-12-01 05:25:10 UTC
REVIEW: http://review.gluster.org/8380 (barrier: barrier error messages betterment) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 8 Mike McCune 2016-03-28 22:14:36 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 Amar Tumballi 2018-08-29 03:37:29 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.