Bug 1123821 - The old artifact repository can not be removed from UI by Admin.
Summary: The old artifact repository can not be removed from UI by Admin.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: manstis
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 10:52 UTC by yuli wang
Modified: 2014-07-28 11:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 11:07:06 UTC
Type: Bug


Attachments (Terms of Use)
no remove button on the artifact repository (138.97 KB, image/png)
2014-07-28 10:52 UTC, yuli wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1051848 None None None Never

Internal Links: 1051848

Description yuli wang 2014-07-28 10:52:43 UTC
Created attachment 921751 [details]
no remove button on the artifact repository

Description of problem:
As summary.

Version-Release number of selected component (if applicable):
6.0.1

How reproducible:
100%

Steps to Reproduce:
1. Upload an old jar file which name is Sysloan-1.0.2.jar with package name is not 1.0.2.
2. New a deployment unit for Sysloan-1.0.2.
3. Check the process definition list, found there is no new process definition for Sysloan-1.0.2 because the package name is not update.
4. Update the jar file and Re-upload the Sysloan-1.0.2.
5. Redeploy Sysloan-1.0.2 and check the process definition list.

Actual Result:
There is still no Sysloan-1.0.2 process in the definition list.
and user can not remove the old Sysloan-1.0.2 artifact repository from repository list, maybe the artifact file is updated although upload a new jar file.

Expected Result:
Admin can remove the old Sysloan-1.0.2 file from artifact repository.
The new same name jar file can not deployed in the bpms site


Note You need to log in before you can comment on or make changes to this bug.