Bug 1123835 - '/usr/libexec/telepathy-haze' crashes while adding contacts
Summary: '/usr/libexec/telepathy-haze' crashes while adding contacts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: telepathy-haze
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1133060
TreeView+ depends on / blocked
 
Reported: 2014-07-28 11:45 UTC by Siteshwar Vashisht
Modified: 2019-08-15 03:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 08:40:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2230 normal SHIPPED_LIVE empathy bug fix and enhancement update 2015-11-19 09:03:21 UTC
FreeDesktop.org 47005 None None None Never

Description Siteshwar Vashisht 2014-07-28 11:45:44 UTC
Description of problem:
'/usr/libexec/telepathy-haze' crashes while adding contacts.

Version-Release number of selected component (if applicable):
telepathy-haze-0.7.0-7.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login AOL Instant Messenger (AIM) account
2. Readd a contact which already exists in contact list

Actual results:
'/usr/libexec/telepathy-haze' crashes and empathy shows internal error.

Expected results:
'/usr/libexec/telepathy-haze' should not crash.

Additional info:

This is the backtrace of the crash :

#0  0x00007f21b7b20989 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007f21b7b22098 in __GI_abort () at abort.c:90
#2  0x00007f21b856f186 in g_assertion_message (domain=domain@entry=0x42154d "haze", file=file@entry=0x423289 "contact-list.c", line=line@entry=537, 
    func=func@entry=0x423360 <__PRETTY_FUNCTION__.35347> "haze_contact_list_request_subscription", message=<optimized out>) at gtestutils.c:1912
#3  0x00007f21b856f1e4 in g_assertion_message_expr (domain=domain@entry=0x42154d "haze", file=file@entry=0x423289 "contact-list.c", line=line@entry=537, 
    func=func@entry=0x423360 <__PRETTY_FUNCTION__.35347> "haze_contact_list_request_subscription", expr=expr@entry=0x423250 "purple_find_buddy (account, bname) == NULL") at gtestutils.c:1923
#4  0x00000000004155bf in haze_contact_list_request_subscription (self=self@entry=0x1d1b920, handle=<optimized out>, message=message@entry=0x20c1c20 "") at contact-list.c:537
#5  0x000000000041565f in haze_contact_list_request_subscription_async (cl=<optimized out>, contacts=0x20c2120, message=0x20c1c20 "", 
    callback=0x7f21b81d69b0 <tp_base_contact_list_mixin_request_subscription_cb>, user_data=0x20e3e90) at contact-list.c:563
#6  0x00007f21b81dde6b in tp_base_contact_list_mixin_request_subscription (svc=<optimized out>, contacts=0x20c0980, message=0x20c1c20 "", context=0x20e3e90) at base-contact-list.c:5147
#7  0x00007f21b5ca5dac in ffi_call_unix64 () at ../src/x86/unix64.S:76
#8  0x00007f21b5ca56d5 in ffi_call (cif=cif@entry=0x7fffd8bb8710, fn=<optimized out>, rvalue=0x7fffd8bb8680, avalue=avalue@entry=0x7fffd8bb8600) at ../src/x86/ffi64.c:522
#9  0x00007f21b883b338 in g_cclosure_marshal_generic (closure=0x7fffd8bb8920, return_gvalue=0x0, n_param_values=<optimized out>, param_values=<optimized out>, invocation_hint=<optimized out>, 
    marshal_data=0x7f21b82408e0 <tp_svc_connection_interface_contact_list_request_subscription>) at gclosure.c:1454
#10 0x00007f21b902b843 in invoke_object_method (message=0x20d8700, connection=0x1cb1380, method=0x7f21b84f2f38 <_tp_svc_connection_interface_contact_list_methods+24>, 
    object_info=0x7f21b84f1440 <_tp_svc_connection_interface_contact_list_object_info>, object=0x1d3a000) at dbus-gobject.c:1899
#11 object_registration_message (connection=0x1cb1380, message=message@entry=0x20d8700, user_data=user_data@entry=0x1d246a0) at dbus-gobject.c:2161
#12 0x00007f21b8df3c86 in _dbus_object_tree_dispatch_and_unlock (tree=0x1cb1080, message=message@entry=0x20d8700, found_object=found_object@entry=0x7fffd8bb8b44) at dbus-object-tree.c:862
#13 0x00007f21b8de5e49 in dbus_connection_dispatch (connection=connection@entry=0x1cb1380) at dbus-connection.c:4672
#14 0x00007f21b9028d35 in message_queue_dispatch (source=source@entry=0x1cb4690, callback=<optimized out>, user_data=<optimized out>) at dbus-gmain.c:90
#15 0x00007f21b854aac6 in g_main_dispatch (context=0x1cb45d0) at gmain.c:3058
#16 g_main_context_dispatch (context=context@entry=0x1cb45d0) at gmain.c:3634
#17 0x00007f21b854ae48 in g_main_context_iterate (context=0x1cb45d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3705
#18 0x00007f21b854b25a in g_main_loop_run (loop=0x1d14ac0) at gmain.c:3899
#19 0x00007f21b821e74f in tp_run_connection_manager (prog_name=prog_name@entry=0x42154d "haze", version=version@entry=0x42145f "0.7.0", construct_cm=construct_cm@entry=0x40e790 <get_cm>, 
    argc=argc@entry=1, argv=argv@entry=0x7fffd8bb8e28) at run.c:285
#20 0x000000000040e62b in main (argc=1, argv=0x7fffd8bb8e28) at main.c:262

Comment 1 Debarshi Ray 2015-04-28 17:18:07 UTC
Siteshwar, can you please check if the patch in the upstream bug [1] fixes this?

[1] https://bugs.freedesktop.org/show_bug.cgi?id=47005

Comment 2 Debarshi Ray 2015-04-30 14:21:14 UTC
I verified that it addresses the issue.

Comment 3 Debarshi Ray 2015-04-30 15:41:40 UTC
I have submitted telepathy-haze-0.7.0-8.el7 with this fix:
https://brewweb.devel.redhat.com/taskinfo?taskID=9077560

Comment 4 Matěj Cepl 2015-05-13 13:33:22 UTC
Cannot reproduce with telepathy-haze-0.8.0-1.el7.x86_64 and libpurple-2.10.7-22.el7.x86_64

Comment 8 errata-xmlrpc 2015-11-19 08:40:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2230.html


Note You need to log in before you can comment on or make changes to this bug.