Bug 1123837 - hammer import repository refuses to import a internal repo - invalid source_url [NEEDINFO]
Summary: hammer import repository refuses to import a internal repo - invalid source_url
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Matej Kollar
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-07-28 11:54 UTC by Lukas Pramuk
Modified: 2014-09-11 12:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:29:15 UTC
ggainey: needinfo? (aupadhye)


Attachments (Terms of Use)

Description Lukas Pramuk 2014-07-28 11:54:17 UTC
Description of problem:
if you have repo defined with just hostname hammer import repository refuses to import it and shows msg about invalid source_url, e.g.
"Skipping proxy560-rhel6-x86_64 repository import, invalid source_url."

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_import-0.8.0-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. @sat5: have defined a repository using just hostname (not fqdn)
2. spacewalk-export
3. hammer import repository --csv-file /tmp/exports/repositories.csv


Actual results:
it refuses to import repos with urls just made of hostname (not fqdn)

Expected results:
it should import repos even with such urls

Additional info:
/tmp/exports/repositories.csv:
66,620,proxy560-rhel6-x86_64,yum,http://download/released/Proxy-5.6-RHEL-6/x86_64/tree/RHNProxy/,,,,,,,,,

Comment 1 Matej Kollar 2014-07-28 12:06:34 UTC
hammer-cli-import.git: b4cf49ea9e9a0c86cd1c4442d7a10c9d2a2e8a5f

Comment 2 RHEL Product and Program Management 2014-07-28 12:23:56 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Lukas Pramuk 2014-08-25 16:51:20 UTC
VERIFIED. rubygem-hammer_cli_import-0.10.1-1.el6.noarch

# cat /tmp/exports/repositories.csv
org_id,id,repo_label,repo_type,source_url,client_key_descr,client_key_type,client_key,client_cert_descr,client_cert_type,client_cert,ca_descr,ca_type,ca_key
66,620,proxy560-rhel6-x86_64,yum,http://download/released/Proxy-5.6-RHEL-6/x86_64/tree/RHNProxy/,,,,,,,,,

# hammer import repository --csv-file /tmp/exports/repositories.csv
Summary
  Created 1 repository.
  Created 1 product.

Comment 9 Matej Kollar 2014-09-03 08:00:20 UTC
Unless csv (or at least hostname) that this fails on is provided I can not do anything about it as I am unable to reproduce it with data provided in comment #0

Comment 10 Matej Kollar 2014-09-03 08:02:37 UTC
Providing traceback would also not hurt.

Comment 11 Matej Kollar 2014-09-03 11:38:51 UTC
Unable to reproduce, moving back to ON_QA.
Please open a new BZ if you can find a reproducer and mention there this bug.

Comment 12 Grant Gainey 2014-09-04 19:02:04 UTC
Can't reproduce, already VERIFIED by QE - returning to VERIFIED, which is where we were when this started.

Comment 13 Bryan Kearney 2014-09-11 12:29:15 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.