Bug 1123841 - Resized images cannot be viewed properly
Summary: Resized images cannot be viewed properly
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: opencv-2.4.9
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 12:14 UTC by Vern
Modified: 2015-06-30 01:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 01:36:14 UTC


Attachments (Terms of Use)

Description Vern 2014-07-28 12:14:18 UTC
Description of problem:

Images that are resized cannot be viewed properly.  Once they are resized it's as if digikam only remembers the original size in the preview windows.  So if you view at 100% it scales the image to the original size.  This was a known bug in 4.0 that was supposedly fixed in 4.1.  I installed 4.1 from another repository and the problem still exists to some degree.  In 4.0 you could not reduce the size of the viewed image.  After you resized, it could only be viewed upscaled to the size of the original image.  In 4.1 you can now resize the image, but it cannot be viewed at 100% of it's true size.  This probably should be listed as a critical error, as it makes editing virtually impossible, especially sharpening, which needs to be done with a true 100% view.  Since this was fixed in 4.1 I believe that this is maybe a dependency issue that has not been resolved in the latest package.  In any event 4.1 should be offered for Fedora 20 as it's known to fix several critical bugs.

Version-Release number of selected component (if applicable):
4.0 and 4.1

How reproducible:
Every time

Steps to Reproduce:
1. Open large image
2. Resize image to small size
3. Try to view image at 100%

Actual results:

Image viewed at 100% will be scaled terribly to very large size, most likely the size of the original image.  Image cannot be viewed at it's true size.

Expected results:

Image viewed at 100% should not be scaled.  If it is scaled, this should be reflected in the %view indicator, for example it should indiciate the image is being viewed at 400%, and you should be able to change it to 100%.  With properly functioning Digikam, I believe when you resize an image, it stays scaled at whatever the original is scaled at in the view.  For example, if you were viewing the original at 33%, when you resized it, you would be viewing the new image at 33% also.  This is not the behavior in 4.0 and it's impossible to correctly view a resized image for editing.

Additional info:

This problem wsa not fixed with the 4.1 version of Digikam installed from the repository listed in another bugzilla report here.  It has been fixed upstream in 4.1.  Possible dependency issue.

Comment 1 Fedora Update System 2014-08-17 22:09:57 UTC
digikam-4.2.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/digikam-4.2.0-5.fc20

Comment 2 Fedora Update System 2014-08-19 07:07:51 UTC
Package digikam-4.2.0-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing digikam-4.2.0-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9563/digikam-4.2.0-5.fc20
then log in and leave karma (feedback).

Comment 3 Vern 2014-08-21 12:50:47 UTC
Thanks for your work on this.  I've installed the version from testing and everything else was current on my system (FC20).  This version works fine other than the fact that this bug is still not resolved.  Behavior seems very slightly modified but still the same problem.  I can change the view for a resized image, but the application will still not display a resized image at 100%.  It always scales the image to a much larger resolution, likely the original resolution before resizing.  There are other minor glitches in changing the view, sometimes if I change the percentage for scaling, nothing happens, or the image scales to a random size.  It's just very unpredictable, but generally if I do it a few times it will change the view, just never correctly at 100% which is the most needed view for editing.

Comment 4 Fedora End Of Life 2015-05-29 12:29:46 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2015-06-30 01:36:14 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.