Bug 1123856 - Build of backend rpm failed
Summary: Build of backend rpm failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 2.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space27
TreeView+ depends on / blocked
 
Reported: 2014-07-28 13:30 UTC by Ludwig Bayerlein
Modified: 2017-09-28 18:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-09 12:24:23 UTC


Attachments (Terms of Use)

Description Ludwig Bayerlein 2014-07-28 13:30:37 UTC
Description of problem:
I downloaded the master branch of the github.com repository (version 2.2). The I have downloaded all of the dependencies via yum-builddep und changed the dir into backend. If I simply run "tito build --test --rpm" there is no success. There is no way to create the spacewalk-backend.rpm on the make process. Everytime there comes this output:

"
R0902: 20:ContentPackage: Too many instance attributes (11/7)
************* Module spacewalk.satellite_tools.repo_plugins.yum_src
R0902: 93:ContentSource: Too many instance attributes (11/7)
R0922: 33:BaseCollection: Abstract class is only referenced 1 times
R0921:293:PackageCollection: Abstract class not referenced
error: Bad exit status from /var/tmp/rpm-tmp.GQmUj7 (%check)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.GQmUj7 (%check)


ERROR: Error running command: rpmbuild --define "_source_filedigest_algorithm md5"  --define "_binary_filedigest_algorithm md5"  --eval '%undefine scl' --define "_topdir /tmp/tito/rpmbuild-spacewalk-backend3d0pTq" --define "_sourcedir /tmp/tito/rpmbuild-spacewalk-backend3d0pTq/SOURCES" --define "_builddir /tmp/tito/rpmbuild-spacewalk-backend3d0pTq/BUILD" --define "_srcrpmdir /tmp/tito" --define "_rpmdir /tmp/tito"   --clean -ba /tmp/tito/rpmbuild-spacewalk-backend3d0pTq/SOURCES/spacewalk-backend-git-0.8bbbe70/spacewalk-backend.spec
" 

Version-Release number of selected component (if applicable):
Backend-version: 2.2.43

How reproducible:


Steps to Reproduce:
1. git clone github.com-repo
2. yum-builddep spacewalk/backend/spacewalk-backend.spec
3. cd spacewalk/backend
4. tito build --rpm --test

Actual results:
No success - only some errors and a fail at the end

Expected results:
A rpm for installing this part via yum.

Additional info:
I use the latest 6.5 update of Centos.

Comment 1 Gennadii Altukhov 2016-05-09 12:21:42 UTC
cannot reproduce

Comment 2 Gennadii Altukhov 2016-05-09 12:24:23 UTC
version:
tito-0.6.3-1.el6.noarch

Comment 3 Eric Herget 2017-09-28 18:08:55 UTC
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.


Note You need to log in before you can comment on or make changes to this bug.