Bug 1123862 - API Documentation import_puppetclasses
Summary: API Documentation import_puppetclasses
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs API Guide
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: David O'Brien
QA Contact: Athene Chan
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-07-28 13:42 UTC by Peter Vreman
Modified: 2015-05-11 22:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-17 01:58:44 UTC


Attachments (Terms of Use)

Description Peter Vreman 2014-07-28 13:42:59 UTC
Description of problem:
API doc mentions import_puppet_classes, in the implementation it is called import_puppetclasses

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. curl -K /opt/hoici/etc/curl-hoici.conf -XPOST https://localhost/api/v2/smart_proxies/1/import_puppet_classes
2. curl -K /opt/hoici/etc/curl-hoici.conf -XPOST https://localhost/api/v2/smart_proxies/1/import_puppetclasses
3.

Actual results:

Expected results:
Update either the API implementation or the documentation


Additional info:

Comment 1 RHEL Product and Program Management 2014-07-28 14:04:20 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2014-07-28 22:50:21 UTC
Hi Dominic,

Assigning this to David O'Brien for evaluation and inclusion in the API docs. Thank you!

Athene

Comment 4 Peter Vreman 2014-09-16 15:16:09 UTC
Confirm to be fixed, the Sat6 GA documentation is already corrected.

Comment 5 Athene Chan 2014-09-17 01:58:44 UTC
Thanks Peter! I am closing this request as fixed!

Cheers,
Athene


Note You need to log in before you can comment on or make changes to this bug.