Bug 112387 - pango fails to render text
pango fails to render text
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 14:45 EST by Nicholas Miell
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 09:43:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2003-12-18 14:45:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
After upgrading to the pango-1.2.5-3.0 packages in fc-testing, GNOME
apps subsequently started failed to render any text.

Version-Release number of selected component (if applicable):
1.2.5-3.0

How reproducible:
Always

Steps to Reproduce:
1. Upgrade pango
2. (Re)Start an app that uses pango
3. Admire the lack of text
    

Additional info:

At a guess, I'd say the 32/64 changes have resulted in an inability
for pango to find the appropriate pango.modules file
Comment 1 Owen Taylor 2003-12-18 14:56:31 EST
The problem is that it is looking for:

 /etc/i386-redhat-linux-gnu/pango.modules

but the file is

 /etc/i386-redhat-linux/pango.modules

Symlinking the directories will get your text back until I figure
out the correct munging in the spec file to fix this.
Comment 2 Owen Taylor 2003-12-18 17:12:39 EST
pango-1.2.5-4 fixes, may take a little while to get pushed to 
-testing.
Comment 3 Jim Cornette 2003-12-18 17:32:18 EST
one correction to the location is it is the below:

 /etc/pangoi386-redhat-linux/pango.modules


This fixed the problem though with making a symlinked directory

/etc/pangoi386-redhat-linux-gnu/pango.modules


Thanks!
Comment 4 Jim Cornette 2003-12-18 17:33:07 EST
/etc/pango/i386-redhat-linux/pango.modules
Comment 5 Leonard den Ottolander 2004-04-14 08:56:40 EDT
Has this been resolved? Or is it a duplicate of bug 115329 ?

Note You need to log in before you can comment on or make changes to this bug.