Bug 1123883 - Installation documentation is incomplete
Summary: Installation documentation is incomplete
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite-doc-list
QA Contact: satellite-doc-list
URL:
Whiteboard:
: 1172368 (view as bug list)
Depends On: 1179535 1180715
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1172368
TreeView+ depends on / blocked
 
Reported: 2014-07-28 14:29 UTC by Andrew Schofield
Modified: 2018-08-31 15:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1172368 (view as bug list)
Environment:
Last Closed: 2017-01-05 20:03:51 UTC


Attachments (Terms of Use)

Description Andrew Schofield 2014-07-28 14:29:29 UTC
Description of problem:

In this I am including 4 documentation gaps:


1) The installation guide is not complete. Section 1 has some nice diagrams of how satellite 6 can be configured in a number of different environments. However there is no documentation which would state how you would configure each of the components (via the installer with examples) to achieve those setups. Nor is there any RedHat recommendations as to which setups would be beneficial along with pros and cons of the various setups.

For example, we want to deploy in a heavily centralized environment where all environment configuration is done via the Satellite master and that the Capsule servers are in effect 'black boxes'. This would be 'Figure 1.4' (but without the integrated capsule).

2) There is no indication as to environment sizing. For example, how big (roughly) will the DB on the Satellite master grow to (based on 1,000, 5,000 or 10,000 servers assuming defaults etc) how many clients will each capsule support? 

Also the documentation states 'The bulk of storage resides on the /var/lib/mongodb and /var/lib/pulp directories. These end points are not manually configurable. Make sure that storage is available on the /var filesystem to prevent storage issues.' That's just words! I'd like to see how much space is required. For example if you sync a 20G repo then you will need 20G in pulp + how much per version / org etc + recommended overhead for each dir. 

3) DR / Recovery. How do you DR a satellite server? What if a capsule blows up? - Can you DR these? How do you rebuild one and have the clients restore their connections without intervention.

4) There is no documentation on how to integrate Satellites certificate system with either a commercial CA or an internal corporate CA (note too that our internal CA does not require CSR's - we just get a p12 at the end of the internal process which is easy enough to convert).

Comment 1 RHEL Product and Program Management 2014-07-28 14:33:46 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Athene Chan 2014-07-29 04:30:05 UTC
Hello Andrew,

Thank you for your feedback. I will evaluate your comments and will integrate any changes to the books for the GA Release of Satellite 6. I'll update you as soon as the changes are updated in the book.

Please feel free to provide future feedback should you see any other issues or concerns.

Thank you,
Athene

Comment 6 Athene Chan 2014-08-05 00:10:01 UTC
Hello Andrew,

I've discussed this with our developers. Responses are in-line below:

(In reply to Andrew Schofield from comment #0)
> Description of problem:
> 
> In this I am including 4 documentation gaps:
> 
> 
> 1) The installation guide is not complete. Section 1 has some nice diagrams
> of how satellite 6 can be configured in a number of different environments.
> However there is no documentation which would state how you would configure
> each of the components (via the installer with examples) to achieve those
> setups. Nor is there any RedHat recommendations as to which setups would be
> beneficial along with pros and cons of the various setups.
> 
> For example, we want to deploy in a heavily centralized environment where
> all environment configuration is done via the Satellite master and that the
> Capsule servers are in effect 'black boxes'. This would be 'Figure 1.4' (but
> without the integrated capsule).

There is a future documentation being planned out to provide a more architectural-focused book that should address special configurations. At the moment, the Installation Guide and User Guide provide basic workflows. 

> 
> 2) There is no indication as to environment sizing. For example, how big
> (roughly) will the DB on the Satellite master grow to (based on 1,000, 5,000
> or 10,000 servers assuming defaults etc) how many clients will each capsule
> support? 
> 
> Also the documentation states 'The bulk of storage resides on the
> /var/lib/mongodb and /var/lib/pulp directories. These end points are not
> manually configurable. Make sure that storage is available on the /var
> filesystem to prevent storage issues.' That's just words! I'd like to see
> how much space is required. For example if you sync a 20G repo then you will
> need 20G in pulp + how much per version / org etc + recommended overhead for
> each dir. 
>


We understand your concern on this and agree that some benchmarks are required. At the moment, our current prerequisites are documented here:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/Installation_Guide/Prerequisites3.html

In the GA version the following statements are being added:
1. A minimum of 20 GB storage for each unique software repository. Packages that are duplicated in different channels are only stored once on the disk. Additional repositories containing duplicate packages will require less additional storage. The bulk of storage resides on the /var/lib/mongodb and /var/lib/pulp directories. These end points are not manually configurable. Make sure that storage is available on the /var filesystem to prevent storage issues.

2. A minimum of 2 GB of available storage in /var/lib/pgsql with the ability to grow the partition containing this directory as data storage requirements grow. 

Your request for specific database requirements have been acknowledged, however, these values are not available at this time and may be provided at a future release.

 
> 3) DR / Recovery. How do you DR a satellite server? What if a capsule blows
> up? - Can you DR these? How do you rebuild one and have the clients restore
> their connections without intervention.
> 

Disaster Recovery documentation has been scheduled for future release.

> 4) There is no documentation on how to integrate Satellites certificate
> system with either a commercial CA or an internal corporate CA (note too
> that our internal CA does not require CSR's - we just get a p12 at the end
> of the internal process which is easy enough to convert).

Request #4 will be documented together with this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=754728

Please bear with us as we strive to slowly create documentation tailored to our readers needs. 

Thank you,
Athene Chan

Comment 8 Athene Chan 2015-02-27 01:27:45 UTC
Hi Andrew,

Some updates on what will be included in the next release of Satellite documentation that is relevant to your requests:

1. Filesystem requirements:
https://bugzilla.redhat.com/show_bug.cgi?id=1180715

There are no plans at the moment to create database requirements but we are going to provide more specific FS requirements.

2. For Disaster Recovery:
https://bugzilla.redhat.com/show_bug.cgi?id=1179535

3. Request #4 has been addressed in a previous release:
https://bugzilla.redhat.com/show_bug.cgi?id=754728


Thank you,
Athene

Comment 9 RHEL Product and Program Management 2015-04-21 16:11:05 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 10 Deon Ballard 2015-06-02 15:19:37 UTC
*** Bug 1172368 has been marked as a duplicate of this bug. ***

Comment 11 Deon Ballard 2015-06-02 16:36:12 UTC
Hey, Andrew.

I think, looking at your original request, #1 will still be largely unaddressed for the 6.1 GA. Can we open a separate bug to address that? We need to revisit architecture docs in general, and I think that request fits in.

Comment 12 Andrew Schofield 2015-06-02 17:17:10 UTC
Hi Deon, that should be sufficient, yes.

Comment 16 Andrew Dahms 2016-12-05 06:43:18 UTC
Hi Andrew,

Thank you for raising this bug, and my apologies for the time it has taken for you to receive an update on progress.

My name is Andrew, and I am currently responsible for reviewing bugs for the Satellite documentation and working them into our schedule.

Going over the past comments, it appears that several of your initial requests have been addressed, with the main outstanding issue being that raised in #1, which asks for more detail about the possible scenarios.

To make sure my understanding is correct, I would be keen to hear if you feel there is anything outstanding from any of the items, or whether we can close this bug in its role as a tracker.

In particular, with the Satellite 6.2 documentation, we have now created a new Architecture Guide that provides some more detail about the scenarios and architecture for Satellite 6 in general -

https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/architecture-guide#chap-Red_Hat_Satellite-Architecture_Guide-Deployment_Scenarios

Do the links that have been added to the documentation here provide sufficient guidance for what you were seeking, or are you looking for a more comprehensive overview?

Let me know what you think.

Kind regards,

Andrew

Comment 17 Bryan Kearney 2017-01-05 20:03:51 UTC
I emailed with Andrew, here is hte response:

<Andrew>
This can be closed out. It was raised 2014 against 6.0.x (I think!) and the documentation has substantially improved since then.
</Andrew>

Comment 18 Andrew Dahms 2017-05-11 12:05:41 UTC
Clearing old needinfo request.


Note You need to log in before you can comment on or make changes to this bug.