Bug 1123916 - [AS7] app is not discovered if two versions are installed simultaneously
Summary: [AS7] app is not discovered if two versions are installed simultaneously
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-42
TreeView+ depends on / blocked
 
Reported: 2014-07-28 15:48 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 07:44:41 UTC
Type: Bug


Attachments (Terms of Use)
app_versions (362.08 KB, image/png)
2014-07-28 15:48 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-07-28 15:48:11 UTC
Created attachment 921812 [details]
app_versions

Description of problem:
[AS7] app is not discovered if two versions are installed simultaneously 

Version-Release number of selected component (if applicable):
 RHQ 4.13 master

How reproducible:
always

Steps to Reproduce:
1. install jon (rhqctl install --start) with rhq.as7.VersionedSubsystemDiscovery.pattern enabled
2. install 2 versions of the same app simultaneously to EAP6 
3.

Actual results:
No all is discovered 

Expected results:
either app with biggest version is discovered and active, or, meaningful log is logged telling how to get app discovered.


Additional info:
screen-shot attached

Comment 1 Jay Shaughnessy 2014-07-28 17:57:14 UTC

This is expected behavior.  We don't discover either versioned app if they both resolve to the same logical app.  This is to protect the user, really, because in this situation it would appear they intend to have two separate apps.

You should see in your agent log a WARN level message:

  "Discovered multiple resources with resource key [XYZ].  This is not allowed
   and they will be removed from discovery.  This is typically caused by having
   multiple versions of the same Deployment deployed.  To solve the problem
   either remove all but one version of the problem deployment or disable
   versioned deployment handling by setting
     -Drhq.as7.VersionedSubsystemDiscovery.pattern=disable
   for the agent."

As long as you see this message it's working as expected and is not a bug.

Comment 2 Armine Hovsepyan 2014-07-29 07:44:41 UTC
Lack of test case: I've had a expected result as app with biggest version is discovered.

Closing as not a bug.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.