Bug 1123959 - changing the content view of a content host does not affect the content view of the (Foreman) host
Summary: changing the content view of a content host does not affect the content view ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1103248 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 18:02 UTC by Erik M Jacobs
Modified: 2016-04-22 16:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:30:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7069 None None None 2016-04-22 16:18:40 UTC

Description Erik M Jacobs 2014-07-28 18:02:28 UTC
Description of problem:
When you edit a Content Host in Katello and change its content view, the change is saved successfully.

However, when you then visit that host in Foreman it is still using whatever content view was previously associated with it.

This disconnect presents a problem, I would think.

1) If I try to install a package, which CV is it coming from? Katello? Foreman?

2) If I try to add a puppet module, which CV is it coming from?

And so on and so forth.

Comment 1 RHEL Product and Program Management 2014-07-28 18:03:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2014-08-13 16:03:20 UTC
Created redmine issue http://projects.theforeman.org/issues/7069 from this bug

Comment 4 Brad Buckingham 2014-08-15 13:37:00 UTC
Proposed fix in Katello PR: 
https://github.com/Katello/katello/pull/4583

Comment 7 Brad Buckingham 2014-08-28 19:52:50 UTC
*** Bug 1103248 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2014-09-11 12:30:13 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.