Bug 11240 - agpgart module kills xfree86/kernel after unload/reload
agpgart module kills xfree86/kernel after unload/reload
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 07:15 EDT by Frank Ch. Eigler
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 08:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2000-05-05 07:15:07 EDT
On an i810-based motherboard (Intel CA810EAL), the agpgart kernel module
generally works all right with XFree86 3.3.6.

However, if the kernel module is auto-loaded (by associating char-minor-175
in /etc/conf.modules), only the first few X sessions work.  After a
multi-hour break of the machine sitting in console mode, a subsequent X
startup either freezes the kernel/machine completely, or prints a kernel
Oops.

Some experimentation suggests that this may be because the agpgart driver
is not capable of being safely unloaded and reloaded.  If there is not much
time between consecutive X sessions, or if the agpgart driver is loaded by
hand with cleanmod disabled, things don't break.

To reproduce the problem:
* get a kernel RPM with the agpgart module in it
* get an i810-based motherboard
* configure enough stuff to start X correctly at least once
* run X, then kill the server
* optional: run X again right away to confirm that things are still okay
* rmmod agpgart
* insmod agpgart
* run X again.  Observer machine crash or hang or kernel Oops.

(Before the last step, it would be prudent to sync ; umount unneded file
systems.)
Comment 1 Ed McKenzie 2000-07-09 11:44:00 EDT
On a motherboard with a VIA MVP3 chipset running 2.2.14-12, agpgart finds the 
AGP aperture at 0xe8000000 the first time it is loaded, and GLX works well. 
However, if it's unloaded and reloaded, agpgart finds the aperture at 
0x00000000 (and starting X reboots the machine instantly.)

(This is easily reproducible on 2.4 as well.)
Comment 2 Mike A. Harris 2002-02-11 08:13:00 EST
Is this problem still reproduceable in whatever version of RHL you're
using currently, with all updates applied?
Comment 3 Ed McKenzie 2002-02-11 08:56:20 EST
This works on 7.2.  I believe Alan Cox fixed this sometime during the beta cycle for 7.1
Comment 4 Mike A. Harris 2002-02-11 09:09:11 EST
Thanks, closing bug report.

Note You need to log in before you can comment on or make changes to this bug.